summaryrefslogtreecommitdiffstats
path: root/include/cmake.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-01-03 14:44:30 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-01-03 14:44:30 +0000
commit48fc1f97812324325df214362955ee02f97d6e84 (patch)
treec0ebb052135c073bea430c15705940c86f335964 /include/cmake.mk
parent23953244a89e435f000da7bf1c5d84df588f2233 (diff)
downloadmaster-31e0f0ae-48fc1f97812324325df214362955ee02f97d6e84.tar.gz
master-31e0f0ae-48fc1f97812324325df214362955ee02f97d6e84.tar.bz2
master-31e0f0ae-48fc1f97812324325df214362955ee02f97d6e84.zip
build: for cmake, always use ccache from staging dir instead of relying on the host
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 48079
Diffstat (limited to 'include/cmake.mk')
-rw-r--r--include/cmake.mk5
1 files changed, 1 insertions, 4 deletions
diff --git a/include/cmake.mk b/include/cmake.mk
index 4207a4dcee..4e4169a132 100644
--- a/include/cmake.mk
+++ b/include/cmake.mk
@@ -18,10 +18,7 @@ ifeq ($(CONFIG_CCACHE),)
CMAKE_C_COMPILER_ARG1:=
CMAKE_CXX_COMPILER_ARG1:=
else
- CCACHE:=$(shell which ccache)
- ifeq ($(CCACHE),)
- CCACHE:=$(STAGING_DIR_HOST)/bin/ccache
- endif
+ CCACHE:=$(STAGING_DIR_HOST)/bin/ccache
CMAKE_C_COMPILER:=$(CCACHE)
CMAKE_C_COMPILER_ARG1:=$(TARGET_CC_NOCACHE)
CMAKE_CXX_COMPILER:=$(CCACHE)