summaryrefslogtreecommitdiffstats
path: root/include/cmake.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2011-04-11 02:11:11 +0000
committerJo-Philipp Wich <jow@openwrt.org>2011-04-11 02:11:11 +0000
commit0f13d0a0681a6dfd57cd4634ce62c7419438e87c (patch)
tree6ea4dc429dbc177c9a45c1cc1e1263218e0d1b36 /include/cmake.mk
parent718f5aa78e12c2a40182e264cd17b64f09d4b6ee (diff)
downloadmaster-31e0f0ae-0f13d0a0681a6dfd57cd4634ce62c7419438e87c.tar.gz
master-31e0f0ae-0f13d0a0681a6dfd57cd4634ce62c7419438e87c.tar.bz2
master-31e0f0ae-0f13d0a0681a6dfd57cd4634ce62c7419438e87c.zip
cmake.mk: don't assume toolchain binaries in .../bin/ if an external toolchain is used, rely on `which` instead
SVN-Revision: 26584
Diffstat (limited to 'include/cmake.mk')
-rw-r--r--include/cmake.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/include/cmake.mk b/include/cmake.mk
index c83be1522e..22255acf59 100644
--- a/include/cmake.mk
+++ b/include/cmake.mk
@@ -3,10 +3,17 @@ PKG_INSTALL:=1
MAKE_FLAGS+=VERBOSE=1
ifeq ($(CONFIG_CCACHE),)
+ ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
CMAKE_C_COMPILER:=$(TOOLCHAIN_DIR)/bin/$(TARGET_CC)
CMAKE_C_COMPILER_ARG1:=
CMAKE_CXX_COMPILER:=$(TOOLCHAIN_DIR)/bin/$(TARGET_CXX)
CMAKE_CXX_COMPILER_ARG1:=
+ else
+ CMAKE_C_COMPILER:=$(shell which $(TARGET_CC))
+ CMAKE_C_COMPILER_ARG1:=
+ CMAKE_CXX_COMPILER:=$(shell which $(TARGET_CXX))
+ CMAKE_CXX_COMPILER_ARG1:=
+ endif
else
CMAKE_C_COMPILER:=$(STAGING_DIR_HOST)/bin/ccache
CMAKE_C_COMPILER_ARG1:=$(filter-out ccache,$(TARGET_CC))