summaryrefslogtreecommitdiffstats
path: root/include/cmake.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-07-24 08:34:08 +0000
committerFelix Fietkau <nbd@openwrt.org>2011-07-24 08:34:08 +0000
commit0d0915d1680be1deba8f662a79261ea1f115cd94 (patch)
treefeb6ac83d79bb40e3a608fee49a5edc341fe03e7 /include/cmake.mk
parent9105dad418a4b4f64395d68bc2c462c3612ea6da (diff)
downloadmaster-31e0f0ae-0d0915d1680be1deba8f662a79261ea1f115cd94.tar.gz
master-31e0f0ae-0d0915d1680be1deba8f662a79261ea1f115cd94.tar.bz2
master-31e0f0ae-0d0915d1680be1deba8f662a79261ea1f115cd94.zip
cmake: fix ccache command when using host ccache (patch from #9611)
SVN-Revision: 27742
Diffstat (limited to 'include/cmake.mk')
-rw-r--r--include/cmake.mk8
1 files changed, 6 insertions, 2 deletions
diff --git a/include/cmake.mk b/include/cmake.mk
index 6c5b5eb4f7..ad9744d3fd 100644
--- a/include/cmake.mk
+++ b/include/cmake.mk
@@ -15,9 +15,13 @@ ifeq ($(CONFIG_CCACHE),)
CMAKE_CXX_COMPILER_ARG1:=
endif
else
- CMAKE_C_COMPILER:=$(STAGING_DIR_HOST)/bin/ccache
+ CCACHE:=$(shell which ccache)
+ ifeq ($(CCACHE),)
+ CCACHE:=$(STAGING_DIR_HOST)/bin/ccache
+ endif
+ CMAKE_C_COMPILER:=$(CCACHE)
CMAKE_C_COMPILER_ARG1:=$(filter-out ccache,$(TARGET_CC))
- CMAKE_CXX_COMPILER:=$(STAGING_DIR_HOST)/bin/ccache
+ CMAKE_CXX_COMPILER:=$(CCACHE)
CMAKE_CXX_COMPILER_ARG1:=$(filter-out ccache,$(TARGET_CXX))
endif