summaryrefslogtreecommitdiffstats
path: root/include/autotools.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-01-20 20:46:20 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-01-20 20:46:20 +0000
commitf8cdadc832a78623edf18c7a5aadadcac136c9a4 (patch)
treecfe36a9d2f83fc72f9da325ece40e3bc2296e2dc /include/autotools.mk
parentc7308bc9f147b9438d183d8e655e5cd087ec2668 (diff)
downloadmaster-31e0f0ae-f8cdadc832a78623edf18c7a5aadadcac136c9a4.tar.gz
master-31e0f0ae-f8cdadc832a78623edf18c7a5aadadcac136c9a4.tar.bz2
master-31e0f0ae-f8cdadc832a78623edf18c7a5aadadcac136c9a4.zip
Revert "include/autoconf.mk: decouple host fixups from target fixups"
This reverts commit r48403 SVN-Revision: 48412
Diffstat (limited to 'include/autotools.mk')
-rw-r--r--include/autotools.mk14
1 files changed, 10 insertions, 4 deletions
diff --git a/include/autotools.mk b/include/autotools.mk
index 3e028fa72d..3316998dc9 100644
--- a/include/autotools.mk
+++ b/include/autotools.mk
@@ -143,21 +143,27 @@ define patch_libtool_host
$(HOST_BUILD_DIR)))
endef
-ifneq ($(filter patch-libtool-host,$(PKG_FIXUP)),)
+ifneq ($(filter patch-libtool,$(PKG_FIXUP)),)
Hooks/HostConfigure/Pre += patch_libtool_host
endif
-ifneq ($(filter patch-libtool-host,$(HOST_FIXUP)),)
+ifneq ($(filter patch-libtool,$(HOST_FIXUP)),)
Hooks/HostConfigure/Pre += $(strip $(call patch_libtool,$(HOST_BUILD_DIR)))
endif
-ifneq ($(filter libtool-host,$(HOST_FIXUP)),)
+ifneq ($(filter libtool,$(HOST_FIXUP)),)
+ ifeq ($(filter no-autoreconf,$(HOST_FIXUP)),)
+ Hooks/HostConfigure/Pre += autoreconf_host
+ endif
+endif
+
+ifneq ($(filter libtool-ucxx,$(HOST_FIXUP)),)
ifeq ($(filter no-autoreconf,$(HOST_FIXUP)),)
Hooks/HostConfigure/Pre += autoreconf_host
endif
endif
-ifneq ($(filter autoreconf-host,$(HOST_FIXUP)),)
+ifneq ($(filter autoreconf,$(HOST_FIXUP)),)
ifeq ($(filter autoreconf,$(Hooks/HostConfigure/Pre)),)
Hooks/HostConfigure/Pre += autoreconf_host
endif