summaryrefslogtreecommitdiffstats
path: root/include/autotools.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-12-08 01:19:52 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-12-08 01:19:52 +0000
commitf3f3be3dfe61d4f48f0749c1f98616c0e52bcda4 (patch)
tree3202bc5359ce2e636f9e6542404b520b3a6098b8 /include/autotools.mk
parent69aeb3a06cae7b6c26fa0d11c98a82f9f6898989 (diff)
downloadmaster-31e0f0ae-f3f3be3dfe61d4f48f0749c1f98616c0e52bcda4.tar.gz
master-31e0f0ae-f3f3be3dfe61d4f48f0749c1f98616c0e52bcda4.tar.bz2
master-31e0f0ae-f3f3be3dfe61d4f48f0749c1f98616c0e52bcda4.zip
autotools.mk: allow autogen.sh / autoreconf to fail (for now)
SVN-Revision: 24320
Diffstat (limited to 'include/autotools.mk')
-rw-r--r--include/autotools.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/autotools.mk b/include/autotools.mk
index 3203604682..df5e85a5f5 100644
--- a/include/autotools.mk
+++ b/include/autotools.mk
@@ -25,10 +25,10 @@ endef
define autoreconf
(cd $(PKG_BUILD_DIR); \
if [ -x ./autogen.sh ]; then \
- ./autogen.sh; \
+ ./autogen.sh || true; \
elif [ -f ./configure.ac ] || [ -f ./configure.in ]; then \
$(STAGING_DIR_HOST)/bin/autoreconf -v -f -i -s \
- $(patsubst %,-I %,$(PKG_LIBTOOL_PATHS)) $(PKG_LIBTOOL_PATHS); \
+ $(patsubst %,-I %,$(PKG_LIBTOOL_PATHS)) $(PKG_LIBTOOL_PATHS) || true; \
fi \
);
endef