summaryrefslogtreecommitdiffstats
path: root/include/autotools.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-03-29 03:38:40 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-03-29 03:38:40 +0000
commite10df8d2b5f0422eb49d856fc5064d7975c8e6f0 (patch)
tree74d2f85ad542c4f621a9d2c840340f20dc4a21ee /include/autotools.mk
parent965f7700830e6dd75fc10436846bd275291f27cd (diff)
downloadmaster-31e0f0ae-e10df8d2b5f0422eb49d856fc5064d7975c8e6f0.tar.gz
master-31e0f0ae-e10df8d2b5f0422eb49d856fc5064d7975c8e6f0.tar.bz2
master-31e0f0ae-e10df8d2b5f0422eb49d856fc5064d7975c8e6f0.zip
add a new helper macro to deal with conditional ./configure flags
SVN-Revision: 20570
Diffstat (limited to 'include/autotools.mk')
-rw-r--r--include/autotools.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/autotools.mk b/include/autotools.mk
index e1535d0b16..c941a4949d 100644
--- a/include/autotools.mk
+++ b/include/autotools.mk
@@ -32,6 +32,7 @@ update_libtool_ucxx = \
) \
$(call update_libtool_common)
+autoconf_bool = $(patsubst %,$(if $($(1)),--enable,--disable)-%,$(2))
# prevent libtool from linking against host development libraries
define libtool_fixup_libdir