summaryrefslogtreecommitdiffstats
path: root/include/autotools.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-01-20 19:12:28 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-01-20 19:12:28 +0000
commitd542d8e3c1d56d1ec065fb15c9dd2ca14ac23326 (patch)
treeff3eec44bfb685609f0d642a4b9594de8acf678d /include/autotools.mk
parent4c030333a370bf423eabfbc85fe633fe6cdd7d64 (diff)
downloadmaster-31e0f0ae-d542d8e3c1d56d1ec065fb15c9dd2ca14ac23326.tar.gz
master-31e0f0ae-d542d8e3c1d56d1ec065fb15c9dd2ca14ac23326.tar.bz2
master-31e0f0ae-d542d8e3c1d56d1ec065fb15c9dd2ca14ac23326.zip
include/autoconf.mk: decouple host fixups from target fixups
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 48403
Diffstat (limited to 'include/autotools.mk')
-rw-r--r--include/autotools.mk14
1 files changed, 4 insertions, 10 deletions
diff --git a/include/autotools.mk b/include/autotools.mk
index 3316998dc9..3e028fa72d 100644
--- a/include/autotools.mk
+++ b/include/autotools.mk
@@ -143,27 +143,21 @@ define patch_libtool_host
$(HOST_BUILD_DIR)))
endef
-ifneq ($(filter patch-libtool,$(PKG_FIXUP)),)
+ifneq ($(filter patch-libtool-host,$(PKG_FIXUP)),)
Hooks/HostConfigure/Pre += patch_libtool_host
endif
-ifneq ($(filter patch-libtool,$(HOST_FIXUP)),)
+ifneq ($(filter patch-libtool-host,$(HOST_FIXUP)),)
Hooks/HostConfigure/Pre += $(strip $(call patch_libtool,$(HOST_BUILD_DIR)))
endif
-ifneq ($(filter libtool,$(HOST_FIXUP)),)
- ifeq ($(filter no-autoreconf,$(HOST_FIXUP)),)
- Hooks/HostConfigure/Pre += autoreconf_host
- endif
-endif
-
-ifneq ($(filter libtool-ucxx,$(HOST_FIXUP)),)
+ifneq ($(filter libtool-host,$(HOST_FIXUP)),)
ifeq ($(filter no-autoreconf,$(HOST_FIXUP)),)
Hooks/HostConfigure/Pre += autoreconf_host
endif
endif
-ifneq ($(filter autoreconf,$(HOST_FIXUP)),)
+ifneq ($(filter autoreconf-host,$(HOST_FIXUP)),)
ifeq ($(filter autoreconf,$(Hooks/HostConfigure/Pre)),)
Hooks/HostConfigure/Pre += autoreconf_host
endif