summaryrefslogtreecommitdiffstats
path: root/include/autotools.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-06-11 21:50:50 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-06-11 21:50:50 +0000
commitd40fe9d24ec6802cf86a710fbbcad6437a951559 (patch)
treebf2d68cbcb9dd467ce8fd8d7926d1dcfa0b1ad31 /include/autotools.mk
parentb43599598c8e65da3d4ed734f05fbfb7822ab6ec (diff)
downloadmaster-31e0f0ae-d40fe9d24ec6802cf86a710fbbcad6437a951559.tar.gz
master-31e0f0ae-d40fe9d24ec6802cf86a710fbbcad6437a951559.tar.bz2
master-31e0f0ae-d40fe9d24ec6802cf86a710fbbcad6437a951559.zip
autotools.mk: cope with Debian version strings in libtool
SVN-Revision: 32207
Diffstat (limited to 'include/autotools.mk')
-rw-r--r--include/autotools.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/include/autotools.mk b/include/autotools.mk
index c5ba748ab9..8796598569 100644
--- a/include/autotools.mk
+++ b/include/autotools.mk
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2007-2011 OpenWrt.org
+# Copyright (C) 2007-2012 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -51,9 +51,9 @@ endef
# 1: build dir
define patch_libtool
- (cd $(1); \
+ @(cd $(1); \
for lt in $$$$($$(STAGING_DIR_HOST)/bin/find . -name ltmain.sh); do \
- lt_version="$$$$($$(STAGING_DIR_HOST)/bin/sed -ne 's,^[[:space:]]*VERSION=\([0-9]\.[0-9]\+\).*,\1,p' $$$$lt)"; \
+ lt_version="$$$$($$(STAGING_DIR_HOST)/bin/sed -ne 's,^[[:space:]]*VERSION="\?\([0-9]\.[0-9]\+\).*,\1,p' $$$$lt)"; \
case "$$$$lt_version" in \
1.5|2.2|2.4) echo "autotools.mk: Found libtool v$$$$lt_version - applying patch to $$$$lt"; \
(cd $$$$(dirname $$$$lt) && $$(PATCH) -N -s -p1 < $$(TOPDIR)/tools/libtool/files/libtool-v$$$$lt_version.patch || true) ;; \