summaryrefslogtreecommitdiffstats
path: root/include/autotools.mk
diff options
context:
space:
mode:
authorLars-Peter Clausen <lars@metafoo.de>2010-02-18 23:50:44 +0000
committerLars-Peter Clausen <lars@metafoo.de>2010-02-18 23:50:44 +0000
commitd38ce9313b0cbe3f48edec87ee23e9f5be523a06 (patch)
tree715fe1513ce84e85f5ec2ba17d46ede32958c713 /include/autotools.mk
parent8d7a6df6efe3c870f0b40d13b03b4de09e47c24b (diff)
downloadmaster-31e0f0ae-d38ce9313b0cbe3f48edec87ee23e9f5be523a06.tar.gz
master-31e0f0ae-d38ce9313b0cbe3f48edec87ee23e9f5be523a06.tar.bz2
master-31e0f0ae-d38ce9313b0cbe3f48edec87ee23e9f5be523a06.zip
autotools.mk: Add PKG_LIBTOOL_PATHS variable.
PKG_LIBTOOL_PATHS can be used to specify to tell libtool_fixup where to look for libtool scripts of a package. This is useful if a package has it's libtool script in a non-standard location or has multiple libtool scripts. The value should be a space seperated list of paths which are relative to $(PKG_BUILD_DIR). It defautls to $(CONFIGURE_PATH). SVN-Revision: 19713
Diffstat (limited to 'include/autotools.mk')
-rw-r--r--include/autotools.mk24
1 files changed, 19 insertions, 5 deletions
diff --git a/include/autotools.mk b/include/autotools.mk
index cd333577c1..f85026a944 100644
--- a/include/autotools.mk
+++ b/include/autotools.mk
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2007-2009 OpenWrt.org
+# Copyright (C) 2007-2010 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -13,10 +13,24 @@ define replace
endef
+PKG_LIBTOOL_PATHS?=$(CONFIGURE_PATH)
+
# replace copies of ltmain.sh with the build system's version
-update_libtool_common=$(call replace,ltmain.sh,$(STAGING_DIR)/host/share/libtool,$(CONFIGURE_PATH)/)$(call replace,libtool.m4,$(STAGING_DIR)/host/share/aclocal,$(CONFIGURE_PATH)/)
-update_libtool=$(call replace,libtool,$(STAGING_DIR)/host/bin,$(CONFIGURE_PATH)/)$(call update_libtool_common)
-update_libtool_ucxx=$(call replace,libtool,$(STAGING_DIR)/host/bin,$(CONFIGURE_PATH)/,libtool-ucxx)$(call update_libtool_common)
+update_libtool_common = \
+ $(foreach p,$(LIBTOOL_PATHS), \
+ $(call replace,ltmain.sh,$(STAGING_DIR)/host/share/libtool,$(p)/) \
+ $(call replace,libtool.m4,$(STAGING_DIR)/host/share/aclocal,$(p)/) \
+ )
+update_libtool = \
+ $(foreach p,$(PKG_LIBTOOL_PATHS), \
+ $(call replace,libtool,$(STAGING_DIR)/host/bin,$(p)/) \
+ ) \
+ $(call update_libtool_common)
+update_libtool_ucxx = \
+ $(foreach p,$(PKG_LIBTOOL_PATHS), \
+ $(call replace,libtool,$(STAGING_DIR)/host/bin,$(p)/,libtool-ucxx) \
+ ) \
+ $(call update_libtool_common)
# prevent libtool from linking against host development libraries
@@ -32,7 +46,7 @@ endef
define remove_version_check
if [ -f "$(PKG_BUILD_DIR)/$(CONFIGURE_PATH)/configure" ]; then \
$(SED) \
- 's,pardus_ltmain_version=.*,pardus_ltmain_version="$$$$pardus_lt_version",' \
+ 's,\(gentoo\|pardus\)_ltmain_version=.*,\1_ltmain_version="$$$$\1_lt_version",' \
$(PKG_BUILD_DIR)/$(CONFIGURE_PATH)/configure; \
fi
endef