summaryrefslogtreecommitdiffstats
path: root/include/autotools.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-08-19 17:46:11 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-08-19 17:46:11 +0000
commitc4b3e38fc00270e30b346df6d16cd5c3a921193f (patch)
treedb471db8ecf7482f75dfc30079a79105a4c02f7f /include/autotools.mk
parente8487a49e417076ce0a8bec53f662ae61d51df62 (diff)
downloadmaster-31e0f0ae-c4b3e38fc00270e30b346df6d16cd5c3a921193f.tar.gz
master-31e0f0ae-c4b3e38fc00270e30b346df6d16cd5c3a921193f.tar.bz2
master-31e0f0ae-c4b3e38fc00270e30b346df6d16cd5c3a921193f.zip
fix libtool fixup for libstdc++
SVN-Revision: 22732
Diffstat (limited to 'include/autotools.mk')
-rw-r--r--include/autotools.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/autotools.mk b/include/autotools.mk
index c941a4949d..1ddb49b7d4 100644
--- a/include/autotools.mk
+++ b/include/autotools.mk
@@ -38,7 +38,7 @@ autoconf_bool = $(patsubst %,$(if $($(1)),--enable,--disable)-%,$(2))
define libtool_fixup_libdir
find $(1) -name '*.la' | $(XARGS) \
$(SED) "s,\(^libdir='\| \|-L\|^dependency_libs='\)/usr/lib,\1$(STAGING_DIR)/usr/lib,g" \
- -e "s,$(STAGING_DIR)/usr/lib/\(libstdc++\|libsupc++\).la,$(TOOLCHAIN_DIR)/usr/lib/\1.la,g"
+ -e "s,$(STAGING_DIR)/usr/lib/\(libstdc++\|libsupc++\).la,$(TOOLCHAIN_DIR)/lib/\1.la,g"
endef
define remove_version_check