summaryrefslogtreecommitdiffstats
path: root/include/autotools.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-12-13 01:44:28 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-12-13 01:44:28 +0000
commitc48a7057025bd7462fb025d8d6b519d842b5961e (patch)
treed6906b9790b4dfa092c60e4a712ee1a4d04b331c /include/autotools.mk
parent9f47e80bb30bed05ebcdfe671d4f2a9e9c7bfe55 (diff)
downloadmaster-31e0f0ae-c48a7057025bd7462fb025d8d6b519d842b5961e.tar.gz
master-31e0f0ae-c48a7057025bd7462fb025d8d6b519d842b5961e.tar.bz2
master-31e0f0ae-c48a7057025bd7462fb025d8d6b519d842b5961e.zip
autotools.mk: support autoreconf at different paths, introduce PKG_AUTOMAKE_PATHS which defaults to '.'
SVN-Revision: 24534
Diffstat (limited to 'include/autotools.mk')
-rw-r--r--include/autotools.mk23
1 files changed, 13 insertions, 10 deletions
diff --git a/include/autotools.mk b/include/autotools.mk
index 32b512e26c..4a7c10bf86 100644
--- a/include/autotools.mk
+++ b/include/autotools.mk
@@ -6,6 +6,7 @@
#
PKG_LIBTOOL_PATHS?=$(CONFIGURE_PATH)
+PKG_AUTOMAKE_PATHS?=$(CONFIGURE_PATH)
PKG_REMOVE_FILES?=aclocal.m4
autoconf_bool = $(patsubst %,$(if $($(1)),--enable,--disable)-%,$(2))
@@ -19,16 +20,18 @@ endef
define autoreconf
(cd $(PKG_BUILD_DIR); \
$(patsubst %,rm -f %;,$(PKG_REMOVE_FILES)) \
- if [ -x ./autogen.sh ]; then \
- ./autogen.sh || true; \
- elif [ -f ./configure.ac ] || [ -f ./configure.in ]; then \
- [ -f ./aclocal.m4 ] && [ ! -f ./acinclude.m4 ] && mv aclocal.m4 acinclude.m4; \
- [ -d ./autom4te.cache ] && rm -rf autom4te.cache; \
- $(STAGING_DIR_HOST)/bin/autoreconf -v -f -i -s \
- -B $(STAGING_DIR_HOST)/share/aclocal \
- -B $(STAGING_DIR)/host/share/aclocal \
- $(patsubst %,-I %,$(PKG_LIBTOOL_PATHS)) $(PKG_LIBTOOL_PATHS) || true; \
- fi \
+ $(foreach p,$(PKG_AUTOMAKE_PATHS), \
+ if [ -x $(p)/autogen.sh ]; then \
+ $(p)/autogen.sh || true; \
+ elif [ -f $(p)/configure.ac ] || [ -f $(p)/configure.in ]; then \
+ [ -f $(p)/aclocal.m4 ] && [ ! -f $(p)/acinclude.m4 ] && mv aclocal.m4 acinclude.m4; \
+ [ -d $(p)/autom4te.cache ] && rm -rf autom4te.cache; \
+ $(STAGING_DIR_HOST)/bin/autoreconf -v -f -i -s \
+ -B $(STAGING_DIR_HOST)/share/aclocal \
+ -B $(STAGING_DIR)/host/share/aclocal \
+ $(patsubst %,-I %,$(PKG_LIBTOOL_PATHS)) $(PKG_LIBTOOL_PATHS) || true; \
+ fi; \
+ ) \
);
endef