summaryrefslogtreecommitdiffstats
path: root/include/autotools.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-12-04 19:56:47 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-12-04 19:56:47 +0000
commitc10515db657c15f268f558626df4d594e37ee6d8 (patch)
tree6d6bf17291cfe1c6a2ac7b92e4a431414bb0a275 /include/autotools.mk
parent56ae0b91e2b08689f705f57fdb93dd88a87400a7 (diff)
downloadmaster-31e0f0ae-c10515db657c15f268f558626df4d594e37ee6d8.tar.gz
master-31e0f0ae-c10515db657c15f268f558626df4d594e37ee6d8.tar.bz2
master-31e0f0ae-c10515db657c15f268f558626df4d594e37ee6d8.zip
re-enable the libtool PKG_BUILD_DEPENDS for PKG_FIXUP and emit a deprecation warning. Packages must specify PKG_BUILD_DEPENDS:=libtool
SVN-Revision: 24246
Diffstat (limited to 'include/autotools.mk')
-rw-r--r--include/autotools.mk23
1 files changed, 9 insertions, 14 deletions
diff --git a/include/autotools.mk b/include/autotools.mk
index 20227474cb..534add6425 100644
--- a/include/autotools.mk
+++ b/include/autotools.mk
@@ -57,18 +57,13 @@ endef
Hooks/InstallDev/Post += libtool_remove_files
-# XXX the libtool fixups got deactivated in the course of switching to libtool2 in trunk XXX
-# ifneq ($(filter libtool,$(PKG_FIXUP)),)
-# PKG_BUILD_DEPENDS += libtool
-# Hooks/Configure/Pre += update_libtool remove_version_check
-# Hooks/Configure/Post += update_libtool
-# Hooks/InstallDev/Post += libtool_fixup_libdir
-# endif
-#
-# ifneq ($(filter libtool-ucxx,$(PKG_FIXUP)),)
-# PKG_BUILD_DEPENDS += libtool
-# Hooks/Configure/Pre += update_libtool_ucxx remove_version_check
-# Hooks/Configure/Post += update_libtool_ucxx
-# Hooks/InstallDev/Post += libtool_fixup_libdir
-# endif
+ifneq ($(filter libtool,$(PKG_FIXUP)),)
+ # WARNING: the use of PKG_FIXUP is DEPRECATED
+ PKG_BUILD_DEPENDS += libtool
+endif
+
+ifneq ($(filter libtool-ucxx,$(PKG_FIXUP)),)
+ # WARNING: the use of PKG_FIXUP is DEPRECATED
+ PKG_BUILD_DEPENDS += libtool
+endif