summaryrefslogtreecommitdiffstats
path: root/include/autotools.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-10-10 17:53:51 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-10-10 17:53:51 +0000
commit70749275330c71f0cbd4f815a1713923365d6d13 (patch)
tree2256ecbfe59296ae8ca1ccb5ca7722b88602428c /include/autotools.mk
parent109cf29629e6527898e8e54d756753380c2ba864 (diff)
downloadmaster-31e0f0ae-70749275330c71f0cbd4f815a1713923365d6d13.tar.gz
master-31e0f0ae-70749275330c71f0cbd4f815a1713923365d6d13.tar.bz2
master-31e0f0ae-70749275330c71f0cbd4f815a1713923365d6d13.zip
autotools.mk: add a gettext-version PKG_FIXUP (#11236)
This fixup aligns the required gettext version in shipped macros to the one available in $(STAGING_DIR_HOST). SVN-Revision: 33708
Diffstat (limited to 'include/autotools.mk')
-rw-r--r--include/autotools.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/include/autotools.mk b/include/autotools.mk
index 8796598569..7ebeff6c76 100644
--- a/include/autotools.mk
+++ b/include/autotools.mk
@@ -83,6 +83,15 @@ define patch_libtool_target
$(PKG_BUILD_DIR)))
endef
+define gettext_version_target
+ cd $(PKG_BUILD_DIR) && \
+ GETTEXT_VERSION=$(shell $(STAGING_DIR_HOST)/bin/gettext -V | $(STAGING_DIR_HOST)/bin/sed -ne '1s/.* //p') && \
+ $(STAGING_DIR_HOST)/bin/sed \
+ -i $(PKG_BUILD_DIR)/configure.ac \
+ -e "s/AM_GNU_GETTEXT_VERSION(\[.*\])/AM_GNU_GETTEXT_VERSION(\[$$$$GETTEXT_VERSION\])/g" && \
+ $(STAGING_DIR_HOST)/bin/autopoint --force
+endef
+
ifneq ($(filter patch-libtool,$(PKG_FIXUP)),)
Hooks/Configure/Pre += patch_libtool_target
endif
@@ -107,6 +116,10 @@ ifneq ($(filter autoreconf,$(PKG_FIXUP)),)
endif
endif
+ifneq ($(filter gettext-version,$(PKG_FIXUP)),)
+ Hooks/Configure/Pre += gettext_version_target
+endif
+
HOST_FIXUP?=$(PKG_FIXUP)
HOST_LIBTOOL_PATHS?=$(if $(PKG_LIBTOOL_PATHS),$(PKG_LIBTOOL_PATHS),.)