summaryrefslogtreecommitdiffstats
path: root/include/autotools.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-12-08 15:55:05 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-12-08 15:55:05 +0000
commit6541593b34822f528ff0e1ccd04eb42b51c599c6 (patch)
tree3faf8e1cdafddafe5e0fe848b73f16a3d7e68431 /include/autotools.mk
parent00d3084235ad42fa45a06107682feff1fdf2ed41 (diff)
downloadmaster-31e0f0ae-6541593b34822f528ff0e1ccd04eb42b51c599c6.tar.gz
master-31e0f0ae-6541593b34822f528ff0e1ccd04eb42b51c599c6.tar.bz2
master-31e0f0ae-6541593b34822f528ff0e1ccd04eb42b51c599c6.zip
autotools.mk: introduce PKG_REMOVE_FILES to delete certain files after applying patches and before doing any fixups
SVN-Revision: 24348
Diffstat (limited to 'include/autotools.mk')
-rw-r--r--include/autotools.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/include/autotools.mk b/include/autotools.mk
index a1a5d5d815..b236aace48 100644
--- a/include/autotools.mk
+++ b/include/autotools.mk
@@ -17,11 +17,13 @@ endef
define autoreconf
(cd $(PKG_BUILD_DIR); \
+ $(patsubst %,rm -f %;,$(PKG_REMOVE_FILES)) \
if [ -x ./autogen.sh ]; then \
./autogen.sh || true; \
elif [ -f ./configure.ac ] || [ -f ./configure.in ]; then \
- rm -f ./GNUmakefile; \
+ [ -f ./aclocal.m4 ] && [ ! -f ./acinclude.m4 ] && mv aclocal.m4 acinclude.m4; \
$(STAGING_DIR_HOST)/bin/autoreconf -v -f -i -s \
+ -B $(STAGING_DIR)/host/share/aclocal \
$(patsubst %,-I %,$(PKG_LIBTOOL_PATHS)) $(PKG_LIBTOOL_PATHS) || true; \
fi \
);