summaryrefslogtreecommitdiffstats
path: root/include/autotools.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-12-27 02:11:07 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-12-27 02:11:07 +0000
commit5c2991d8bc17d458831c87dd6b4d2e3e229fd6cf (patch)
tree317ca8ab3c7dc3815d35e283c7a2170051736d4b /include/autotools.mk
parent01dd5fc03aec5e2e0590b469bb17709dcb841861 (diff)
downloadmaster-31e0f0ae-5c2991d8bc17d458831c87dd6b4d2e3e229fd6cf.tar.gz
master-31e0f0ae-5c2991d8bc17d458831c87dd6b4d2e3e229fd6cf.tar.bz2
master-31e0f0ae-5c2991d8bc17d458831c87dd6b4d2e3e229fd6cf.zip
add improved autotools fixups
SVN-Revision: 9942
Diffstat (limited to 'include/autotools.mk')
-rw-r--r--include/autotools.mk30
1 files changed, 30 insertions, 0 deletions
diff --git a/include/autotools.mk b/include/autotools.mk
new file mode 100644
index 0000000000..fd57e64727
--- /dev/null
+++ b/include/autotools.mk
@@ -0,0 +1,30 @@
+#
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define replace
+ if [ -f "$(PKG_BUILD_DIR)/$(3)$(1)" -a -e "$(2)/$(1)" ]; then \
+ rm -f $(PKG_BUILD_DIR)/$(3)$(1); \
+ ln -s $(2)/$(1) $(PKG_BUILD_DIR)/$(3); \
+ fi
+
+endef
+
+# replace copies of ltmain.sh with the build system's version
+update_libtool=$(call replace,libtool,$(STAGING_DIR)/host/bin,$(CONFIGURE_PATH)/)$(call replace,ltmain.sh,$(STAGING_DIR)/host/share/libtool,$(CONFIGURE_PATH)/)
+
+# prevent libtool from linking against host development libraries
+define libtool_fixup_libdir
+ find $(PKG_BUILD_DIR) -name '*.la' | $(XARGS) \
+ $(SED) "s,^libdir='/usr/lib',libdir='$(strip $(1))/usr/lib',g"
+endef
+
+ifneq ($(filter libtool,$(PKG_FIXUP)),)
+ PKG_BUILD_DEPENDS += libtool
+ Hooks/Configure/Pre += update_libtool
+ Hooks/Configure/Post += update_libtool
+ Hooks/Build/Post += libtool_fixup_libdir
+endif