summaryrefslogtreecommitdiffstats
path: root/include/autotools.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-12-08 00:54:14 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-12-08 00:54:14 +0000
commit591190e215c9d5958f2630550164963f69db57aa (patch)
tree6c8ab2d27a83031b2e95b2f9be1b5eac03a0bc29 /include/autotools.mk
parent7224337d713b54376f5d5f451ec0022b3ab41ebb (diff)
downloadmaster-31e0f0ae-591190e215c9d5958f2630550164963f69db57aa.tar.gz
master-31e0f0ae-591190e215c9d5958f2630550164963f69db57aa.tar.bz2
master-31e0f0ae-591190e215c9d5958f2630550164963f69db57aa.zip
deploy the steamroller tactics and autoreconfigure any package carring the libtool fixup, this should solve a number of issues ranging from linking into the host, syntax errors in libtool and missing make targets
SVN-Revision: 24317
Diffstat (limited to 'include/autotools.mk')
-rw-r--r--include/autotools.mk47
1 files changed, 10 insertions, 37 deletions
diff --git a/include/autotools.mk b/include/autotools.mk
index 534add6425..a2d57d6971 100644
--- a/include/autotools.mk
+++ b/include/autotools.mk
@@ -5,65 +5,38 @@
# See /LICENSE for more information.
#
-define replace
- if [ -f "$(PKG_BUILD_DIR)/$(3)$(1)" -a -e "$(2)/$(if $(4),$(4),$(1))" ]; then \
- rm -f $(PKG_BUILD_DIR)/$(3)$(1); \
- ln -s $(2)/$(if $(4),$(4),$(1)) $(PKG_BUILD_DIR)/$(3)$(1); \
- fi
-
-endef
-
PKG_LIBTOOL_PATHS?=$(CONFIGURE_PATH)
-# replace copies of ltmain.sh with the build system's version
-update_libtool_common = \
- $(foreach p,$(LIBTOOL_PATHS), \
- $(call replace,ltmain.sh,$(STAGING_DIR)/host/share/libtool,$(p)/) \
- $(call replace,libtool.m4,$(STAGING_DIR)/host/share/aclocal,$(p)/) \
- )
-update_libtool = \
- $(foreach p,$(PKG_LIBTOOL_PATHS), \
- $(call replace,libtool,$(STAGING_DIR)/host/bin,$(p)/) \
- ) \
- $(call update_libtool_common)
-update_libtool_ucxx = \
- $(foreach p,$(PKG_LIBTOOL_PATHS), \
- $(call replace,libtool,$(STAGING_DIR)/host/bin,$(p)/,libtool-ucxx) \
- ) \
- $(call update_libtool_common)
-
autoconf_bool = $(patsubst %,$(if $($(1)),--enable,--disable)-%,$(2))
# prevent libtool from linking against host development libraries
define libtool_fixup_libdir
find $(1) -name '*.la' | $(XARGS) \
$(SED) "s,\(^libdir='\| \|-L\|^dependency_libs='\)/usr/lib,\1$(STAGING_DIR)/usr/lib,g" \
- -e "s,$(STAGING_DIR)/usr/lib/\(libstdc++\|libsupc++\).la,$(TOOLCHAIN_DIR)/lib/\1.la,g"
-endef
-
-define remove_version_check
- if [ -f "$(PKG_BUILD_DIR)/$(CONFIGURE_PATH)/configure" ]; then \
- $(SED) \
- 's,\(gentoo\|pardus\)_ltmain_version=.*,\1_ltmain_version="$$$$\1_lt_version",' \
- $(PKG_BUILD_DIR)/$(CONFIGURE_PATH)/configure; \
- fi
+ -e "s,$(STAGING_DIR)/usr/lib/\(libstdc++\|libsupc++\).la,$(TOOLCHAIN_DIR)/lib/\1.la,g";
endef
# delete *.la-files from staging_dir - we can not yet remove respective lines within all package
# Makefiles, since backfire still uses libtool v1.5.x which (may) require those files
define libtool_remove_files
- find $(1) -name '*.la' | $(XARGS) rm -f
+ find $(1) -name '*.la' | $(XARGS) rm -f;
+endef
+
+define autoreconf
+ (cd $(PKG_BUILD_DIR); $(STAGING_DIR_HOST)/bin/autoreconf -v -f -i -s $(patsubst %,-I %,$(PKG_LIBTOOL_PATHS)) $(PKG_LIBTOOL_PATHS));
endef
Hooks/InstallDev/Post += libtool_remove_files
ifneq ($(filter libtool,$(PKG_FIXUP)),)
- # WARNING: the use of PKG_FIXUP is DEPRECATED
PKG_BUILD_DEPENDS += libtool
+ Hooks/Configure/Pre += autoreconf
+ Hooks/InstallDev/Post += libtool_fixup_libdir
endif
ifneq ($(filter libtool-ucxx,$(PKG_FIXUP)),)
- # WARNING: the use of PKG_FIXUP is DEPRECATED
PKG_BUILD_DEPENDS += libtool
+ Hooks/Configure/Pre += autoreconf
+ Hooks/InstallDev/Post += libtool_fixup_libdir
endif