summaryrefslogtreecommitdiffstats
path: root/include/autotools.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-12-27 02:11:11 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-12-27 02:11:11 +0000
commit585a9ff548948b78937db10184e51e2ba9fcceed (patch)
treefc600e8aab4632fa8e89d04462c8218e0031f248 /include/autotools.mk
parent5c2991d8bc17d458831c87dd6b4d2e3e229fd6cf (diff)
downloadmaster-31e0f0ae-585a9ff548948b78937db10184e51e2ba9fcceed.tar.gz
master-31e0f0ae-585a9ff548948b78937db10184e51e2ba9fcceed.tar.bz2
master-31e0f0ae-585a9ff548948b78937db10184e51e2ba9fcceed.zip
fix libtool version checks in some configure scripts
SVN-Revision: 9943
Diffstat (limited to 'include/autotools.mk')
-rw-r--r--include/autotools.mk16
1 files changed, 12 insertions, 4 deletions
diff --git a/include/autotools.mk b/include/autotools.mk
index fd57e64727..2450318251 100644
--- a/include/autotools.mk
+++ b/include/autotools.mk
@@ -14,17 +14,25 @@ define replace
endef
# replace copies of ltmain.sh with the build system's version
-update_libtool=$(call replace,libtool,$(STAGING_DIR)/host/bin,$(CONFIGURE_PATH)/)$(call replace,ltmain.sh,$(STAGING_DIR)/host/share/libtool,$(CONFIGURE_PATH)/)
+update_libtool=$(call replace,libtool,$(STAGING_DIR)/host/bin,$(CONFIGURE_PATH)/)$(call replace,ltmain.sh,$(STAGING_DIR)/host/share/libtool,$(CONFIGURE_PATH)/)$(call replace,libtool.m4,$(STAGING_DIR)/host/share/aclocal,$(CONFIGURE_PATH)/)
# prevent libtool from linking against host development libraries
define libtool_fixup_libdir
find $(PKG_BUILD_DIR) -name '*.la' | $(XARGS) \
- $(SED) "s,^libdir='/usr/lib',libdir='$(strip $(1))/usr/lib',g"
+ $(SED) "s,^libdir='/usr/lib',libdir='$(if $(PKG_INSTALL_DIR),$(PKG_INSTALL_DIR),$(STAGING_DIR))/usr/lib',g"
+endef
+
+define remove_version_check
+ if [ -f "$(PKG_BUILD_DIR)/$(CONFIGURE_PATH)/configure" ]; then \
+ $(SED) \
+ 's,pardus_ltmain_version=.*,pardus_ltmain_version="$$$$pardus_lt_version",' \
+ $(PKG_BUILD_DIR)/$(CONFIGURE_PATH)/configure; \
+ fi
endef
ifneq ($(filter libtool,$(PKG_FIXUP)),)
PKG_BUILD_DEPENDS += libtool
- Hooks/Configure/Pre += update_libtool
+ Hooks/Configure/Pre += update_libtool remove_version_check
Hooks/Configure/Post += update_libtool
- Hooks/Build/Post += libtool_fixup_libdir
+ Hooks/Compile/Post += libtool_fixup_libdir
endif