summaryrefslogtreecommitdiffstats
path: root/include/autotools.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-12-08 02:24:21 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-12-08 02:24:21 +0000
commit48b953fa1c8afbd8bb4f1db00d6b2b40c8beee9e (patch)
treee554847b503750022110e8601320178d73ff5699 /include/autotools.mk
parentf3f3be3dfe61d4f48f0749c1f98616c0e52bcda4 (diff)
downloadmaster-31e0f0ae-48b953fa1c8afbd8bb4f1db00d6b2b40c8beee9e.tar.gz
master-31e0f0ae-48b953fa1c8afbd8bb4f1db00d6b2b40c8beee9e.tar.bz2
master-31e0f0ae-48b953fa1c8afbd8bb4f1db00d6b2b40c8beee9e.zip
autotools.mk: allow disabling autoreconf, remove libdir fixup
SVN-Revision: 24321
Diffstat (limited to 'include/autotools.mk')
-rw-r--r--include/autotools.mk13
1 files changed, 4 insertions, 9 deletions
diff --git a/include/autotools.mk b/include/autotools.mk
index df5e85a5f5..9ba3fc33b9 100644
--- a/include/autotools.mk
+++ b/include/autotools.mk
@@ -9,13 +9,6 @@ PKG_LIBTOOL_PATHS?=$(CONFIGURE_PATH)
autoconf_bool = $(patsubst %,$(if $($(1)),--enable,--disable)-%,$(2))
-# prevent libtool from linking against host development libraries
-define libtool_fixup_libdir
- find $(1) -name '*.la' | $(XARGS) \
- $(SED) "s,\(^libdir='\| \|-L\|^dependency_libs='\)/usr/lib,\1$(STAGING_DIR)/usr/lib,g" \
- -e "s,$(STAGING_DIR)/usr/lib/\(libstdc++\|libsupc++\).la,$(TOOLCHAIN_DIR)/lib/\1.la,g";
-endef
-
# delete *.la-files from staging_dir - we can not yet remove respective lines within all package
# Makefiles, since backfire still uses libtool v1.5.x which (may) require those files
define libtool_remove_files
@@ -37,13 +30,15 @@ Hooks/InstallDev/Post += libtool_remove_files
ifneq ($(filter libtool,$(PKG_FIXUP)),)
PKG_BUILD_DEPENDS += libtool
+ ifeq ($(filter no-autoreconf,$(PKG_FIXUP)),)
Hooks/Configure/Pre += autoreconf
- Hooks/InstallDev/Post += libtool_fixup_libdir
+ endif
endif
ifneq ($(filter libtool-ucxx,$(PKG_FIXUP)),)
PKG_BUILD_DEPENDS += libtool
+ ifeq ($(filter no-autoreconf,$(PKG_FIXUP)),)
Hooks/Configure/Pre += autoreconf
- Hooks/InstallDev/Post += libtool_fixup_libdir
+ endif
endif