summaryrefslogtreecommitdiffstats
path: root/include/autotools.mk
diff options
context:
space:
mode:
authorLars-Peter Clausen <lars@metafoo.de>2009-06-04 00:20:01 +0000
committerLars-Peter Clausen <lars@metafoo.de>2009-06-04 00:20:01 +0000
commit246a5b334d62829fa46c3a6bbaf6f0d1e3745fe0 (patch)
treed5293884ca2d345a1568abaecbf8d0d3d9949337 /include/autotools.mk
parent782cd2cf27035153ff52e988551408165eb238ce (diff)
downloadmaster-31e0f0ae-246a5b334d62829fa46c3a6bbaf6f0d1e3745fe0.tar.gz
master-31e0f0ae-246a5b334d62829fa46c3a6bbaf6f0d1e3745fe0.tar.bz2
master-31e0f0ae-246a5b334d62829fa46c3a6bbaf6f0d1e3745fe0.zip
More libtool madness: Every package which was using c++ and libtool fixup was linked against libstd++ even though if it should have been linked against uclibc++. This is fixed by providing a special version of libtool fixup for packages which should use uclibc++. Not pretty but functional. Packages linking against uclibc++ should use PKG_FIXUP:=libtool-ucxx instead of PKG_FIXUP:=libtool
Somebody should probably check all packages using c++ with a dependency on stdlibc++ if uclibc++ can be used instead now. SVN-Revision: 16317
Diffstat (limited to 'include/autotools.mk')
-rw-r--r--include/autotools.mk19
1 files changed, 15 insertions, 4 deletions
diff --git a/include/autotools.mk b/include/autotools.mk
index 558e247fd8..5d51d7a328 100644
--- a/include/autotools.mk
+++ b/include/autotools.mk
@@ -1,20 +1,23 @@
#
-# Copyright (C) 2007-2008 OpenWrt.org
+# Copyright (C) 2007-2009 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
define replace
- if [ -f "$(PKG_BUILD_DIR)/$(3)$(1)" -a -e "$(2)/$(1)" ]; then \
+ if [ -f "$(PKG_BUILD_DIR)/$(3)$(1)" -a -e "$(2)/$(if $(4),$(4),$(1))" ]; then \
rm -f $(PKG_BUILD_DIR)/$(3)$(1); \
- ln -s $(2)/$(1) $(PKG_BUILD_DIR)/$(3); \
+ ln -s $(2)/$(if $(4),$(4),$(1)) $(PKG_BUILD_DIR)/$(3)$(1); \
fi
endef
# replace copies of ltmain.sh with the build system's version
-update_libtool=$(call replace,libtool,$(STAGING_DIR)/host/bin,$(CONFIGURE_PATH)/)$(call replace,ltmain.sh,$(STAGING_DIR)/host/share/libtool,$(CONFIGURE_PATH)/)$(call replace,libtool.m4,$(STAGING_DIR)/host/share/aclocal,$(CONFIGURE_PATH)/)
+update_libtool_common=$(call replace,ltmain.sh,$(STAGING_DIR)/host/share/libtool,$(CONFIGURE_PATH)/)$(call replace,libtool.m4,$(STAGING_DIR)/host/share/aclocal,$(CONFIGURE_PATH)/)
+update_libtool=$(call replace,libtool,$(STAGING_DIR)/host/bin,$(CONFIGURE_PATH)/)$(call update_libtool_common)
+update_libtool_ucxx=$(call replace,libtool,$(STAGING_DIR)/host/bin,$(CONFIGURE_PATH)/,libtool-ucxx)$(call update_libtool_common)
+
# prevent libtool from linking against host development libraries
define libtool_fixup_libdir
@@ -38,3 +41,11 @@ ifneq ($(filter libtool,$(PKG_FIXUP)),)
Hooks/Configure/Post += update_libtool
Hooks/InstallDev/Post += libtool_fixup_libdir
endif
+
+ifneq ($(filter libtool-ucxx,$(PKG_FIXUP)),)
+ PKG_BUILD_DEPENDS += libtool
+ Hooks/Configure/Pre += update_libtool_ucxx remove_version_check
+ Hooks/Configure/Post += update_libtool_ucxx
+ Hooks/InstallDev/Post += libtool_fixup_libdir
+endif
+