summaryrefslogtreecommitdiffstats
path: root/docs
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-01-25 13:15:57 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-01-25 13:15:57 +0000
commitc449bfea529b9c71a2e5bb96cfb67268802ac53a (patch)
tree35a7d867e811f56ffbdbc8604b95cc03ccf1869e /docs
parentbe8b2870e736a402f14aaccb24ad2054556017bc (diff)
downloadmaster-31e0f0ae-c449bfea529b9c71a2e5bb96cfb67268802ac53a.tar.gz
master-31e0f0ae-c449bfea529b9c71a2e5bb96cfb67268802ac53a.tar.bz2
master-31e0f0ae-c449bfea529b9c71a2e5bb96cfb67268802ac53a.zip
add html output for the documentation (using tex4ht)
SVN-Revision: 6199
Diffstat (limited to 'docs')
-rw-r--r--docs/Makefile19
-rw-r--r--docs/openwrt.tex2
2 files changed, 15 insertions, 6 deletions
diff --git a/docs/Makefile b/docs/Makefile
index 8c3ca646dd..359f4e6308 100644
--- a/docs/Makefile
+++ b/docs/Makefile
@@ -1,14 +1,23 @@
-openwrt.pdf: Makefile openwrt.tex config.tex network.tex network-scripts.tex network-scripts.tex wireless.tex build.tex adding.tex bugs.tex
+MAIN = openwrt.tex
+DEPS = $(MAIN) Makefile config.tex network.tex network-scripts.tex network-scripts.tex wireless.tex build.tex adding.tex bugs.tex
+
+all:
$(MAKE) cleanup
- pdflatex openwrt.tex
- pdflatex openwrt.tex
+ latex $(MAIN)
+ $(MAKE) openwrt.pdf openwrt.html
$(MAKE) cleanup
+
+openwrt.html: $(DEPS)
+ htlatex $(MAIN)
+
+openwrt.pdf: $(DEPS)
+ pdflatex $(MAIN)
clean: cleanup
- rm -f openwrt.pdf
+ rm -f openwrt.pdf openwrt.html openwrt.css
cleanup: FORCE
- rm -f *.log *.aux *.toc *.out
+ rm -f *.log *.aux *.toc *.out *.lg *.dvi *.idv *.4ct *.4tc *.xref *.tmp *.dvi
FORCE:
diff --git a/docs/openwrt.tex b/docs/openwrt.tex
index 753ac46e93..2c07052dac 100644
--- a/docs/openwrt.tex
+++ b/docs/openwrt.tex
@@ -1,6 +1,6 @@
\documentclass[a4paper]{book}
\usepackage[latin9]{inputenc}
-\usepackage[pdftex,bookmarks=true]{hyperref}
+\usepackage[bookmarks=true]{hyperref}
\usepackage[T1]{fontenc}
\usepackage{ae,aecompl,aeguill}
\usepackage{fancyvrb}