summaryrefslogtreecommitdiffstats
path: root/docs
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-02-25 19:13:49 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-02-25 19:13:49 +0000
commit242439e53216b948e4d11dfbf79bd5de30f188a0 (patch)
treed61c29a181852002d8e1c11e6a158ca0b38d5ed6 /docs
parentdf6e68a84144f04fdb140f78ac5afff034376218 (diff)
downloadmaster-31e0f0ae-242439e53216b948e4d11dfbf79bd5de30f188a0.tar.gz
master-31e0f0ae-242439e53216b948e4d11dfbf79bd5de30f188a0.tar.bz2
master-31e0f0ae-242439e53216b948e4d11dfbf79bd5de30f188a0.zip
add prereq checks for the documentation (#1400)
SVN-Revision: 6365
Diffstat (limited to 'docs')
-rw-r--r--docs/Makefile19
1 files changed, 18 insertions, 1 deletions
diff --git a/docs/Makefile b/docs/Makefile
index 359f4e6308..9e888a4af2 100644
--- a/docs/Makefile
+++ b/docs/Makefile
@@ -1,5 +1,12 @@
+ifeq ($(TOPDIR),)
+ TOPDIR:=${CURDIR}/..
+endif
+
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/prereq.mk
+
MAIN = openwrt.tex
-DEPS = $(MAIN) Makefile config.tex network.tex network-scripts.tex network-scripts.tex wireless.tex build.tex adding.tex bugs.tex
+DEPS = $(MAIN) Makefile config.tex network.tex network-scripts.tex network-scripts.tex wireless.tex build.tex adding.tex bugs.tex .prereq
all:
$(MAKE) cleanup
@@ -7,6 +14,10 @@ all:
$(MAKE) openwrt.pdf openwrt.html
$(MAKE) cleanup
+.prereq:
+ $(MAKE) prereq
+ touch $@
+
openwrt.html: $(DEPS)
htlatex $(MAIN)
@@ -19,6 +30,12 @@ clean: cleanup
cleanup: FORCE
rm -f *.log *.aux *.toc *.out *.lg *.dvi *.idv *.4ct *.4tc *.xref *.tmp *.dvi
+$(eval $(call RequireCommand,pdflatex, \
+ You need to install LaTeX to build the OpenWrt documentation \
+))
+$(eval $(call RequireCommand,htlatex, \
+ You need to install tex4ht to build the OpenWrt documentation \
+))
FORCE:
.PHONY: FORCE