summaryrefslogtreecommitdiffstats
path: root/docs/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-10-13 22:41:34 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-10-13 22:41:34 +0000
commit550f17100a5e15f9a5ac96c2923e258c786ac454 (patch)
treef81e67632c355d1c9d1357c3d23728fec2c2267f /docs/Makefile
parent60c1f0f64d23003a19a07d6b9638542130f6641d (diff)
downloadmaster-31e0f0ae-550f17100a5e15f9a5ac96c2923e258c786ac454.tar.gz
master-31e0f0ae-550f17100a5e15f9a5ac96c2923e258c786ac454.tar.bz2
master-31e0f0ae-550f17100a5e15f9a5ac96c2923e258c786ac454.zip
add initial version of our new documentation - not too pretty yet, but will be improved
SVN-Revision: 5060
Diffstat (limited to 'docs/Makefile')
-rw-r--r--docs/Makefile15
1 files changed, 15 insertions, 0 deletions
diff --git a/docs/Makefile b/docs/Makefile
new file mode 100644
index 0000000000..0a4128754b
--- /dev/null
+++ b/docs/Makefile
@@ -0,0 +1,15 @@
+openwrt.pdf: Makefile openwrt.tex config.tex network.tex network-scripts.tex
+ $(MAKE) cleanup
+ pdflatex openwrt.tex
+ pdflatex openwrt.tex
+ $(MAKE) cleanup
+
+clean: cleanup
+ rm -f openwrt.pdf
+
+cleanup: FORCE
+ rm -f *.log *.aux *.toc
+
+
+FORCE:
+.PHONY: FORCE