summaryrefslogtreecommitdiffstats
path: root/config
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-03-21 21:48:12 +0000
committerJohn Crispin <john@openwrt.org>2015-03-21 21:48:12 +0000
commitf9f7c80cd2d1aa7e2b4eccc738a30f72c1c45e32 (patch)
treea2b7542e19524f1ed830f7ca3e99f20c559095d1 /config
parentdbd0e9d0928da62a988a321b797d65c8fbeafeb0 (diff)
downloadmaster-31e0f0ae-f9f7c80cd2d1aa7e2b4eccc738a30f72c1c45e32.tar.gz
master-31e0f0ae-f9f7c80cd2d1aa7e2b4eccc738a30f72c1c45e32.tar.bz2
master-31e0f0ae-f9f7c80cd2d1aa7e2b4eccc738a30f72c1c45e32.zip
kernel: Support kernel options required by systemd
These kernel options are all likely to be widely useful in this modern age, but are immediately useful for systemd support. c.f. http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/sys-apps/systemd/systemd-9999.ebuild?&view=markup#l118 Adapted from a patch by Adam Porter. Signed-off-by: Jeff Waugh <jdub@bethesignal.org> SVN-Revision: 44929
Diffstat (limited to 'config')
-rw-r--r--config/Config-kernel.in34
1 files changed, 28 insertions, 6 deletions
diff --git a/config/Config-kernel.in b/config/Config-kernel.in
index 437a6230d7..a0d9472dcb 100644
--- a/config/Config-kernel.in
+++ b/config/Config-kernel.in
@@ -135,6 +135,18 @@ config KERNEL_DIRECT_IO
bool "Compile the kernel with direct IO support"
default n
+config KERNEL_FHANDLE
+ bool "Compile the kernel with support for fhandle syscalls"
+ default n
+
+config KERNEL_FANOTIFY
+ bool "Compile the kernel with modern file notification support"
+ default n
+
+config KERNEL_BLK_DEV_BSG
+ bool "Compile the kernel with SCSI generic v4 support for any block device"
+ default n
+
config KERNEL_MAGIC_SYSRQ
bool "Compile the kernel with SysRq support"
default y
@@ -184,6 +196,22 @@ config USE_SPARSE
bool "Enable sparse check during kernel build"
default n
+config KERNEL_DEVTMPFS
+ bool "Compile the kernel with device tmpfs enabled"
+ default n
+ help
+ devtmpfs is a simple, kernel-managed /dev filesystem. The kernel creates
+ devices nodes for all registered devices ti simplify boot, but leaves more
+ complex tasks to userspace (e.g. udev).
+
+if KERNEL_DEVTMPFS
+
+ config KERNEL_DEVTMPFS_MOUNT
+ bool "Automatically mount devtmpfs after root filesystem is mounted"
+ default n
+
+endif
+
#
# CGROUP support symbols
#
@@ -501,9 +529,3 @@ config KERNEL_SECCOMP_FILTER
default n
help
Build kernel with support for seccomp BPF programs.
-
-config KERNEL_FHANDLE
- bool "Enable open by fhandle syscalls"
- default n
- help
- Build kernel with support for open by fhandle syscalls