summaryrefslogtreecommitdiffstats
path: root/config
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-07-19 17:01:28 +0200
committerFelix Fietkau <nbd@nbd.name>2016-07-20 10:13:50 +0200
commit673004f9bc127a54935ffb4ca05bfb788fba345c (patch)
tree79d10160ebfa36f7ae750788bfae78055ac238fc /config
parent2b4d21a3e635264eb61ea4111a419917123774c8 (diff)
downloadmaster-31e0f0ae-673004f9bc127a54935ffb4ca05bfb788fba345c.tar.gz
master-31e0f0ae-673004f9bc127a54935ffb4ca05bfb788fba345c.tar.bz2
master-31e0f0ae-673004f9bc127a54935ffb4ca05bfb788fba345c.zip
config: remove options for including kernel/dtb in rootfs
These options were a big design flaw to begin with Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'config')
-rw-r--r--config/Config-images.in41
1 files changed, 0 insertions, 41 deletions
diff --git a/config/Config-images.in b/config/Config-images.in
index f81931e47f..c990b87605 100644
--- a/config/Config-images.in
+++ b/config/Config-images.in
@@ -271,45 +271,4 @@ menu "Target Images"
it will be mounted by PARTUUID which makes the kernel find the
appropriate disk automatically.
-
- menuconfig TARGET_ROOTFS_INCLUDE_KERNEL
- bool "Include kernel in root filesystem"
- depends on TARGET_ROOTFS_UBIFS || TARGET_ROOTFS_EXT4FS
- default n
- help
- Include the kernel image in the rootfs. Typically, the image is placed
- below /boot.
-
- config TARGET_ROOTFS_INCLUDE_UIMAGE
- bool "include uImage" if TARGET_ROOTFS_INCLUDE_KERNEL
- default y
- help
- This option might not apply to all targets. Make sure
- to check target/linux/<your_target>/image/Makefile to
- see if this option will have any effect.
-
- config TARGET_ROOTFS_INCLUDE_ZIMAGE
- bool "include zImage" if TARGET_ROOTFS_INCLUDE_KERNEL
- default y
- help
- This option might not apply to all targets. Make sure
- to check target/linux/<your_target>/image/Makefile to
- see if this option will have any effect.
-
- config TARGET_ROOTFS_INCLUDE_FIT
- bool "include FIT" if TARGET_ROOTFS_INCLUDE_KERNEL
- default y
- help
- This option might not apply to all targets. Make sure
- to check target/linux/<your_target>/image/Makefile to
- see if this option will have any effect.
-
- config TARGET_ROOTFS_INCLUDE_DTB
- bool "Include DTB in root filesystem"
- depends on USES_DEVICETREE && (TARGET_ROOTFS_UBIFS || TARGET_ROOTFS_EXT4FS)
- default n
- help
- Include the device tree blob file(s) in the rootfs. Typically the DTBs
- are placed below /boot.
-
endmenu