summaryrefslogtreecommitdiffstats
path: root/config
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-01-04 23:30:36 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-01-04 23:30:36 +0000
commit33beafa8d88e51907acba6fdece5a35f509934df (patch)
treec2fcc27f7a431271857ee553bd55840d5ee83779 /config
parent48a57b1eaddc99c1df778afe07eacd8a204e8829 (diff)
downloadmaster-31e0f0ae-33beafa8d88e51907acba6fdece5a35f509934df.tar.gz
master-31e0f0ae-33beafa8d88e51907acba6fdece5a35f509934df.tar.bz2
master-31e0f0ae-33beafa8d88e51907acba6fdece5a35f509934df.zip
Configure IPv6 kernel options in config/Config-kernel.in
Revision 46834 changed IPv6 support from a module to builtin. But since the configuration of the IPv6 kernel options was left in package/kernel/linux/modules/netsupport.mk, this means that an empty kmod-ipv6 module was still being generated (not packaged). This patch moves the configuration of the IPv6 kernel options to config/Config-kernel.in to remove this last bit of the module. Note that CONFIG_IPV6_PRIVACY was dropped (enabled by default since Linux v3.13), so this option is no longer needed. See https://github.com/torvalds/linux/commit/5d9efa7ee99eed58388f186c13cf2e2a87e9ceb4 Signed-off-by: Arjen de Korte <arjen+openwrt@de-korte.org> SVN-Revision: 48132
Diffstat (limited to 'config')
-rw-r--r--config/Config-kernel.in23
1 files changed, 23 insertions, 0 deletions
diff --git a/config/Config-kernel.in b/config/Config-kernel.in
index 4be5f53b51..6e79bae34b 100644
--- a/config/Config-kernel.in
+++ b/config/Config-kernel.in
@@ -551,3 +551,26 @@ config KERNEL_SECCOMP
default n
help
Build kernel with support for seccomp.
+
+#
+# IPv6 configuration
+#
+
+config KERNEL_IPV6
+ def_bool IPV6
+
+if KERNEL_IPV6
+
+ config KERNEL_IPV6_MULTIPLE_TABLES
+ def_bool y
+
+ config KERNEL_IPV6_SUBTREES
+ def_bool y
+
+ config KERNEL_IPV6_MROUTE
+ def_bool y
+
+ config KERNEL_IPV6_PIMSM_V2
+ def_bool n
+
+endif