summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-03-28 18:01:46 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-03-28 18:01:46 +0000
commite71ae20b0bd6ea6d75637fb5fbfd54992b566c53 (patch)
treead80eaf6e3661171651338c4f77e8a208cc7638d /Makefile
parent92f558c4bea9f0dbcae26c34e73b27a1d2edfb4c (diff)
downloadmaster-31e0f0ae-e71ae20b0bd6ea6d75637fb5fbfd54992b566c53.tar.gz
master-31e0f0ae-e71ae20b0bd6ea6d75637fb5fbfd54992b566c53.tar.bz2
master-31e0f0ae-e71ae20b0bd6ea6d75637fb5fbfd54992b566c53.zip
nuke some unnecessary complexity in the metadata scanning - simply call include/scan.mk on every make invocation (does not add any noticeable performance impact)
SVN-Revision: 6745
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile33
1 files changed, 4 insertions, 29 deletions
diff --git a/Makefile b/Makefile
index 718053e006..bcbfd561b9 100644
--- a/Makefile
+++ b/Makefile
@@ -44,36 +44,11 @@ ifeq ($(FORCE),)
world: tmp/.prereq-packages tmp/.prereq-target
endif
-define stamp
-tmp/info/.stamp-$(1)-$(shell ls $(2)/*/Makefile $(5) | (md5sum || md5) 2>/dev/null | cut -d' ' -f1)
-endef
-
-STAMP_pkginfo=$(call stamp,pkginfo,package)
-STAMP_targetinfo=$(call stamp,targetinfo,target/linux)
-define scan_info
-
-$(STAMP_$(1)):
- @mkdir -p tmp/info
- @rm -f tmp/info/.stamp-$(1)*
- @touch $$@
-
-$(foreach FILE,$(shell ls $(2)/*/Makefile $(5)),
-tmp/.$(1): $(FILE)
-$(FILE):
-)
-
-ifneq ($(5),)
-tmp/.$(1): $(shell ls $(5))
-endif
-
-tmp/.$(1): $(STAMP_$(1)) $(4)
- @echo -n Collecting $(3) info...
- @$(NO_TRACE_MAKE) -s -f include/scan.mk SCAN_TARGET="$(1)" SCAN_DIR="$(2)" SCAN_NAME="$(3)" SCAN_DEPS="$(4)" SCAN_EXTRA="$(5)"
-
-endef
+tmp/.pkginfo: FORCE
+ @$(NO_TRACE_MAKE) -s -f include/scan.mk SCAN_TARGET="pkginfo" SCAN_DIR="package" SCAN_NAME="package" SCAN_DEPS="$(shell ls include/package*.mk) include/kernel.mk" SCAN_EXTRA=""
-$(eval $(call scan_info,pkginfo,package,package,include/package.mk))
-$(eval $(call scan_info,targetinfo,target/linux,target,include/kernel-build.mk include/kernel-version.mk,target/linux/*/profiles/*.mk))
+tmp/.targetinfo: FORCE
+ @$(NO_TRACE_MAKE) -s -f include/scan.mk SCAN_TARGET="targetinfo" SCAN_DIR="target/linux" SCAN_NAME="target" SCAN_DEPS="$(shell ls include/kernel*.mk)" SCAN_EXTRA=""
tmpinfo-clean: FORCE
@-rm -rf tmp/.pkginfo tmp/.targetinfo