summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-07-28 13:29:03 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-07-28 13:29:03 +0000
commite143bed1f19b55c5eac38d78a5c98f478fca88fc (patch)
tree1f3f129a7786dd35da2414d624e8302cbdf08d7a /Makefile
parent9c88ba80b9d566ab7e3dc752fa68ae82aed54212 (diff)
downloadmaster-31e0f0ae-e143bed1f19b55c5eac38d78a5c98f478fca88fc.tar.gz
master-31e0f0ae-e143bed1f19b55c5eac38d78a5c98f478fca88fc.tar.bz2
master-31e0f0ae-e143bed1f19b55c5eac38d78a5c98f478fca88fc.zip
build system fixes, more cleanup
SVN-Revision: 8207
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile13
1 files changed, 5 insertions, 8 deletions
diff --git a/Makefile b/Makefile
index 92b84bb2a7..6703d90d61 100644
--- a/Makefile
+++ b/Makefile
@@ -1,7 +1,6 @@
# Makefile for OpenWrt
#
-# Copyright (C) 2006 OpenWrt.org
-# Copyright (C) 2006 by Felix Fietkau <openwrt@nbd.name>
+# Copyright (C) 2007 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -9,22 +8,21 @@
all: world
-
TOPDIR:=${CURDIR}
LC_ALL:=C
LANG:=C
IS_TTY:=${shell tty -s && echo 1 || echo 0}
export TOPDIR LC_ALL LANG IS_TTY
-include rules.mk
-
ifneq ($(OPENWRT_BUILD),1)
export OPENWRT_BUILD:=1
- include $(INCLUDE_DIR)/toplevel.mk
+ include $(TOPDIR)/include/toplevel.mk
else
+ include rules.mk
include $(INCLUDE_DIR)/depends.mk
include $(INCLUDE_DIR)/subdir.mk
include tools/Makefile
+ include toolchain/Makefile
clean: FORCE
rm -rf build_* bin tmp
@@ -38,8 +36,7 @@ distclean: dirclean config-clean symlinkclean docs/clean
toolchain/% package/% target/%: FORCE
$(MAKE) -C $(patsubst %/$*,%,$@) $*
-world: .config $(tools/stamp) FORCE
- $(MAKE) toolchain/install
+world: .config $(tools/stamp) $(toolchain/stamp) FORCE
$(MAKE) target/compile
$(MAKE) package/compile
$(MAKE) package/install