summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-11-04 11:42:47 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-11-04 11:42:47 +0000
commitdb87e1f8c14fcdc6ea0da199f8e9dd1b7209c102 (patch)
tree6f4b96fcd063a2aa46787d62d5cdfb04f40ffb8a /Makefile
parentfcdf364d10cf68fc0578446b096b0f5ce38eb6c1 (diff)
downloadmaster-31e0f0ae-db87e1f8c14fcdc6ea0da199f8e9dd1b7209c102.tar.gz
master-31e0f0ae-db87e1f8c14fcdc6ea0da199f8e9dd1b7209c102.tar.bz2
master-31e0f0ae-db87e1f8c14fcdc6ea0da199f8e9dd1b7209c102.zip
fix parallel build issues
SVN-Revision: 9495
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/Makefile b/Makefile
index b67413b887..e56535eac4 100644
--- a/Makefile
+++ b/Makefile
@@ -9,8 +9,7 @@
TOPDIR:=${CURDIR}
LC_ALL:=C
LANG:=C
-IS_TTY:=${shell tty -s && echo 1 || echo 0}
-export TOPDIR LC_ALL LANG IS_TTY
+export TOPDIR LC_ALL LANG
world:
@@ -31,10 +30,13 @@ else
include tools/Makefile
include toolchain/Makefile
-$(toolchain/stamp-compile): $(tools/stamp-compile)
+$(toolchain/stamp-install): $(tools/stamp-install)
$(target/stamp-compile): $(toolchain/stamp-install) $(tools/stamp-install) $(BUILD_DIR)/.prepared
-$(package/stamp-compile): $(target/stamp-compile)
-$(target/stamp-install): $(package/stamp-compile) $(package/stamp-install)
+$(package/stamp-cleanup): $(target/stamp-compile)
+$(package/stamp-compile): $(target/stamp-compile) $(package/stamp-cleanup)
+$(package/stamp-install): $(package/stamp-compile)
+$(package/stamp-rootfs-prepare): $(package/stamp-install)
+$(target/stamp-install): $(package/stamp-compile) $(package/stamp-install) $(package/stamp-rootfs-prepare)
$(BUILD_DIR)/.prepared: Makefile
@mkdir -p $$(dirname $@)