summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-11-12 01:55:28 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-11-12 01:55:28 +0000
commitcf10a1dd5ec950121617cf51b84d00374f86480f (patch)
treea46adfb7283ce958b4a76aeb30369fe34ac682af /Makefile
parent8838ffd68d915fc356836468e30e7a26f1f6150a (diff)
downloadmaster-31e0f0ae-cf10a1dd5ec950121617cf51b84d00374f86480f.tar.gz
master-31e0f0ae-cf10a1dd5ec950121617cf51b84d00374f86480f.tar.bz2
master-31e0f0ae-cf10a1dd5ec950121617cf51b84d00374f86480f.zip
another optimization
SVN-Revision: 5507
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index d6b1b7d618..62a0338746 100644
--- a/Makefile
+++ b/Makefile
@@ -21,10 +21,15 @@ SHELL:=/usr/bin/env bash
export LC_ALL=C
export LANG=C
export TOPDIR=${shell pwd}
-include $(TOPDIR)/include/verbose.mk
ifeq ($(KBUILD_VERBOSE),99)
MAKE:=3>/dev/null $(MAKE)
endif
+ifneq ($(shell tty -s <&3 || echo x),x)
+ IS_TTY=1
+ export IS_TTY
+endif
+
+include $(TOPDIR)/include/verbose.mk
OPENWRTVERSION:=$(RELEASE)
ifneq ($(VERSION),)