summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-08-07 00:04:25 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-08-07 00:04:25 +0000
commitc6bc77ea365704f3f5c79d64aed069792a4e95b1 (patch)
tree28c9265495e6ad751fcae0d27a040b222ff2a215 /Makefile
parent9882253827b16579bbd317f6e8c0deb75b0ca0f3 (diff)
downloadmaster-31e0f0ae-c6bc77ea365704f3f5c79d64aed069792a4e95b1.tar.gz
master-31e0f0ae-c6bc77ea365704f3f5c79d64aed069792a4e95b1.tar.bz2
master-31e0f0ae-c6bc77ea365704f3f5c79d64aed069792a4e95b1.zip
build system cleanup/restructuring as described in http://lists.openwrt.org/pipermail/openwrt-devel/2007-August/001159.html
SVN-Revision: 8362
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile16
1 files changed, 9 insertions, 7 deletions
diff --git a/Makefile b/Makefile
index e035faac25..840c28ff61 100644
--- a/Makefile
+++ b/Makefile
@@ -25,25 +25,27 @@ else
include rules.mk
include $(INCLUDE_DIR)/depends.mk
include $(INCLUDE_DIR)/subdir.mk
- include $(INCLUDE_DIR)/target.mk
include target/Makefile
include package/Makefile
include tools/Makefile
include toolchain/Makefile
$(toolchain/stamp-compile): $(tools/stamp-compile)
-$(target/stamp-compile): $(toolchain/stamp-install) $(tools/stamp-install)
+$(target/stamp-compile): $(toolchain/stamp-install) $(tools/stamp-install) $(BUILD_DIR)/.prepared
$(package/stamp-compile): $(target/stamp-compile)
$(target/stamp-install): $(package/stamp-compile) $(package/stamp-install)
+$(BUILD_DIR)/.prepared: Makefile
+ @mkdir -p $$(dirname $@)
+ @touch $@
+
clean: FORCE
- rm -rf build_* bin tmp
+ rm -rf $(BUILD_DIR) $(BIN_DIR)
+ $(MAKE) target/linux/clean
+ rm -rf $(TMP_DIR)
dirclean: clean
- rm -rf staging_dir_* toolchain_build_* tool_build
-
-distclean: dirclean
- rm -rf dl .config*
+ rm -rf $(STAGING_DIR) $(STAGING_DIR_HOST) $(STAGING_DIR_TOOLCHAIN) $(BUILD_DIR_TOOLCHAIN) $(BUILD_DIR_HOST)
# check prerequisites before starting to build
prereq: $(package/stamp-prereq) $(target/stamp-prereq) ;