summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-12-19 01:23:31 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-12-19 01:23:31 +0000
commita4484d267baf15f4d33af5c0f4c36f55f53a67b9 (patch)
tree3ee79fd71245a1dba62881f292f2b63d67d1b613 /Makefile
parent5aa57f3f70b7df95ccf079aebcbba8e24f766e54 (diff)
downloadmaster-31e0f0ae-a4484d267baf15f4d33af5c0f4c36f55f53a67b9.tar.gz
master-31e0f0ae-a4484d267baf15f4d33af5c0f4c36f55f53a67b9.tar.bz2
master-31e0f0ae-a4484d267baf15f4d33af5c0f4c36f55f53a67b9.zip
cosmetic fixes
SVN-Revision: 5851
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/Makefile b/Makefile
index 447457e269..8bd0bc710a 100644
--- a/Makefile
+++ b/Makefile
@@ -60,23 +60,23 @@ endif
define dumpinfo
@mkdir -p tmp
- @echo -n Collecting package info...
+ @echo -n Collecting $(2) info...
@-for dir in $(1)/*/; do \
[ -f "$${dir}/Makefile" ] || continue; \
- $(call progress,Collecting package info... $${dir%%/}) \
+ $(call progress,Collecting $(2) info: $${dir%%/}) \
echo Source-Makefile: $${dir}Makefile; \
$(NO_TRACE_MAKE) --no-print-dir DUMP=1 -C $$dir 3>/dev/null || echo "ERROR: please fix $${dir}Makefile" >&2; \
echo; \
done > $@
- $(call progress,Collecting package info... done)
- echo
+ @($(call progress,Collecting $(2) info: done))
+ @echo
endef
tmp/.pkginfo:
- $(call dumpinfo,package)
+ $(call dumpinfo,package,package)
tmp/.targetinfo:
- $(call dumpinfo,target/linux)
+ $(call dumpinfo,target/linux,target)
tmpinfo-clean: FORCE
@-rm -rf tmp/.pkginfo tmp/.targetinfo