summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-08-16 16:59:47 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-08-16 16:59:47 +0000
commita3a37d0bb1e9e66c12aa68d0c17dee48a4f7f29e (patch)
tree55e7cb676b6270c01af8c7fc05dc89c545a74109 /Makefile
parenta15a10c85adbfe2a4d5ce0985cbe6ca9cc28f9b7 (diff)
downloadmaster-31e0f0ae-a3a37d0bb1e9e66c12aa68d0c17dee48a4f7f29e.tar.gz
master-31e0f0ae-a3a37d0bb1e9e66c12aa68d0c17dee48a4f7f29e.tar.bz2
master-31e0f0ae-a3a37d0bb1e9e66c12aa68d0c17dee48a4f7f29e.zip
rework parallel building to get rid of some warnings and add back support for parallelizing the kernel build fixes #3882
SVN-Revision: 12322
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index 7e43b44321..7be906fa15 100644
--- a/Makefile
+++ b/Makefile
@@ -20,7 +20,7 @@ ifneq ($(OPENWRT_BUILD),1)
# but we can't include that file in this context
empty:=
space:= $(empty) $(empty)
- _SINGLE=MAKEFLAGS=$(space)
+ _SINGLE=export MAKEFLAGS=$(space);
override OPENWRT_BUILD=1
export OPENWRT_BUILD
@@ -50,7 +50,7 @@ $(BUILD_DIR)/.prepared: Makefile
clean: FORCE
rm -rf $(BUILD_DIR) $(BIN_DIR)
- $(SUBMAKE) target/linux/clean
+ $(_SINGLE)$(SUBMAKE) target/linux/clean
dirclean: clean
rm -rf $(STAGING_DIR) $(STAGING_DIR_HOST) $(STAGING_DIR_TOOLCHAIN) $(TOOLCHAIN_DIR) $(BUILD_DIR_HOST)
@@ -59,7 +59,7 @@ dirclean: clean
tmp/.prereq_packages: .config
unset ERROR; \
for package in $(sort $(prereq-y) $(prereq-m)); do \
- $(NO_TRACE_MAKE) -s -r -C package/$$package prereq || ERROR=1; \
+ $(_SINGLE)$(NO_TRACE_MAKE) -s -r -C package/$$package prereq || ERROR=1; \
done; \
if [ -n "$$ERROR" ]; then \
echo "Package prerequisite check failed."; \
@@ -72,7 +72,7 @@ prereq: $(target/stamp-prereq) tmp/.prereq_packages
prepare: .config $(tools/stamp-install) $(toolchain/stamp-install)
world: prepare $(target/stamp-compile) $(package/stamp-cleanup) $(package/stamp-compile) $(package/stamp-install) $(package/stamp-rootfs-prepare) $(target/stamp-install) FORCE
- $(SUBMAKE) package/index
+ $(_SINGLE)$(SUBMAKE) package/index
# update all feeds, re-create index files, install symlinks
package/symlinks: