summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-07-28 02:44:55 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-07-28 02:44:55 +0000
commit81529c47ec26f951a849c54922db22f38848ed95 (patch)
treeb468d3dd463ba5b6d2a35ef630b23eec4d4f6489 /Makefile
parentf1b2dbceb2dfb162db1dc76cfd71d53eba7fa7be (diff)
downloadmaster-31e0f0ae-81529c47ec26f951a849c54922db22f38848ed95.tar.gz
master-31e0f0ae-81529c47ec26f951a849c54922db22f38848ed95.tar.bz2
master-31e0f0ae-81529c47ec26f951a849c54922db22f38848ed95.zip
initial attempt at cleaning up subdirectory handling. tools/Makefile is now being included instead of recursively called
SVN-Revision: 8201
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/Makefile b/Makefile
index dbb4a0cce1..ad3b3b8e12 100644
--- a/Makefile
+++ b/Makefile
@@ -23,7 +23,10 @@ export LANG=C
export TOPDIR=${CURDIR}
export IS_TTY=$(shell tty -s && echo 1 || echo 0)
-include $(TOPDIR)/include/verbose.mk
+include ./rules.mk
+include $(INCLUDE_DIR)/depends.mk
+include $(INCLUDE_DIR)/subdir.mk
+include tools/Makefile
OPENWRTVERSION:=$(RELEASE)
ifneq ($(VERSION),)
@@ -100,7 +103,7 @@ kernel_menuconfig: .config FORCE
package/% target/%: tmp/.packageinfo
toolchain/% package/% target/%: tmp/.targetinfo
-package/% target/% tools/% toolchain/%: FORCE
+package/% target/% toolchain/%: FORCE
$(MAKE) -C $(patsubst %/$*,%,$@) $*
@@ -130,8 +133,7 @@ download: .config FORCE
$(MAKE) package/download
$(MAKE) target/download
-world: .config FORCE
- $(MAKE) tools/install
+world: .config $(tools/stamp) FORCE
$(MAKE) toolchain/install
$(MAKE) target/compile
$(MAKE) package/compile
@@ -162,5 +164,4 @@ symlinkclean:
rm -rf tmp
.SILENT: clean dirclean distclean symlinkclean config-clean download world help tmp/.packageinfo tmp/.targetinfo tmpinfo-clean tmp/.config-package.in tmp/.config-target.in .config scripts/config/mconf scripts/config/conf menuconfig tmp/.prereq-build tmp/.prereq-package tmp/.prereq-target
-FORCE: ;
-.PHONY: FORCE help
+.PHONY: help