summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-10-13 22:51:49 +0200
committerFelix Fietkau <nbd@openwrt.org>2016-03-20 17:29:15 +0100
commit60c1f0f64d23003a19a07d6b9638542130f6641d (patch)
tree8fb2787f4c49baded97cd55e0c371fe1cffce2b6 /Makefile
parentd58a09110ccfa95f06c983fe796806f2e035c9d2 (diff)
parentb3ce218b51746d3a576221ea542facf3a1703ab2 (diff)
downloadmaster-31e0f0ae-60c1f0f64d23003a19a07d6b9638542130f6641d.tar.gz
master-31e0f0ae-60c1f0f64d23003a19a07d6b9638542130f6641d.tar.bz2
master-31e0f0ae-60c1f0f64d23003a19a07d6b9638542130f6641d.zip
finally move buildroot-ng to trunk
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile141
1 files changed, 141 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000000..39ffb17fb5
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,141 @@
+# Makefile for OpenWrt
+#
+# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006 by Felix Fietkau <openwrt@nbd.name>
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+RELEASE:=Kamikaze
+#VERSION:=2.0 # uncomment for final release
+
+#--------------------------------------------------------------
+# Just run 'make menuconfig', configure stuff, then run 'make'.
+# You shouldn't need to mess with anything beyond this point...
+#--------------------------------------------------------------
+
+all: world
+
+SHELL:=/usr/bin/env bash
+export TOPDIR=${shell pwd}
+include $(TOPDIR)/include/verbose.mk
+
+OPENWRTVERSION:=$(RELEASE)
+ifneq ($(VERSION),)
+ OPENWRTVERSION:=$(VERSION) ($(OPENWRTVERSION))
+else
+ REV:=$(shell LANG=C svn info | awk '/^Revision:/ { print$$2 }' )
+ ifneq ($(REV),)
+ OPENWRTVERSION:=$(OPENWRTVERSION)/r$(REV)
+ endif
+endif
+export OPENWRTVERSION
+
+ifneq ($(shell ./scripts/timestamp.pl -p .pkginfo package Makefile),.pkginfo)
+ .pkginfo .config: FORCE
+endif
+
+ifeq ($(FORCE),)
+ .config scripts/config/conf scripts/config/mconf: .prereq-build
+ world: .prereq-packages
+endif
+
+.pkginfo:
+ @echo Collecting package info...
+ @-for dir in package/*/; do \
+ echo Source-Makefile: $${dir}Makefile; \
+ $(NO_TRACE_MAKE) --no-print-dir DUMP=1 -C $$dir || echo "ERROR: please fix $${dir}Makefile" >&2; \
+ done > $@
+
+pkginfo-clean: FORCE
+ -rm -f .pkginfo .config.in
+
+.config.in: .pkginfo
+ @./scripts/gen_menuconfig.pl < $< > $@ || rm -f $@
+
+.config: ./scripts/config/conf .config.in
+ @[ -f .config ] || $(NO_TRACE_MAKE) menuconfig
+ @$< -D .config Config.in &> /dev/null
+
+scripts/config/mconf:
+ @$(MAKE) -C scripts/config all
+
+scripts/config/conf:
+ @$(MAKE) -C scripts/config conf
+
+config: scripts/config/conf .config.in FORCE
+ $< Config.in
+
+config-clean: FORCE
+ $(NO_TRACE_MAKE) -C scripts/config clean
+
+defconfig: scripts/config/conf .config.in FORCE
+ touch .config
+ $< -D .config Config.in
+
+oldconfig: scripts/config/conf .config.in FORCE
+ $< -o Config.in
+
+menuconfig: scripts/config/mconf .config.in FORCE
+ $< Config.in
+
+package/%: .pkginfo FORCE
+ $(MAKE) -C package $(patsubst package/%,%,$@)
+
+target/%: .pkginfo FORCE
+ $(MAKE) -C target $(patsubst target/%,%,$@)
+
+tools/%: FORCE
+ $(MAKE) -C tools $(patsubst tools/%,%,$@)
+
+toolchain/%: FORCE
+ $(MAKE) -C toolchain $(patsubst toolchain/%,%,$@)
+
+.prereq-build: include/prereq-build.mk
+ @$(NO_TRACE_MAKE) -s -f $(TOPDIR)/include/prereq-build.mk prereq 2>/dev/null || { \
+ echo "Prerequisite check failed. Use FORCE=1 to override."; \
+ rm -rf $(TOPDIR)/tmp; \
+ false; \
+ }
+ @rm -rf $(TOPDIR)/tmp
+ @touch $@
+
+.prereq-packages: include/prereq.mk .pkginfo .config
+ @$(NO_TRACE_MAKE) -s -C package prereq 2>/dev/null || { \
+ echo "Prerequisite check failed. Use FORCE=1 to override."; \
+ false; \
+ }
+ @rm -rf "$(TOPDIR)/tmp"
+ @touch $@
+
+prereq: .prereq-build .prereq-packages FORCE
+
+download: .config FORCE
+ $(MAKE) tools/download
+ $(MAKE) toolchain/download
+ $(MAKE) package/download
+ $(MAKE) target/download
+
+world: .config FORCE
+ $(MAKE) tools/install
+ $(MAKE) toolchain/install
+ $(MAKE) target/compile
+ $(MAKE) package/compile
+ $(MAKE) package/install
+ $(MAKE) target/install
+ $(MAKE) package/index
+
+clean: FORCE
+ rm -rf build_* bin
+
+dirclean: clean
+ rm -rf staging_dir_* toolchain_build_* tool_build
+
+distclean: dirclean config-clean
+ rm -rf dl .*config* .pkg* .prereq
+
+.SILENT: clean dirclean distclean config-clean download world
+FORCE: ;
+.PHONY: FORCE
+%: ;