summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-12-19 01:20:44 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-12-19 01:20:44 +0000
commit5aa57f3f70b7df95ccf079aebcbba8e24f766e54 (patch)
treeb4141f1d5ecf4a7c4c0039b5e0f2553c9129f05c /Makefile
parente7798e412f1fdb3737a95774e879d9044d0123ab (diff)
downloadmaster-31e0f0ae-5aa57f3f70b7df95ccf079aebcbba8e24f766e54.tar.gz
master-31e0f0ae-5aa57f3f70b7df95ccf079aebcbba8e24f766e54.tar.bz2
master-31e0f0ae-5aa57f3f70b7df95ccf079aebcbba8e24f766e54.zip
implement real-time progress info for the package/target info collect (thanks to Thorsten Glaser for the idea)
SVN-Revision: 5850
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile27
1 files changed, 17 insertions, 10 deletions
diff --git a/Makefile b/Makefile
index 2dcb727636..447457e269 100644
--- a/Makefile
+++ b/Makefile
@@ -52,24 +52,31 @@ ifeq ($(FORCE),)
world: tmp/.prereq-packages tmp/.prereq-target
endif
-tmp/.pkginfo:
+ifeq ($(IS_TTY),1)
+ define progress
+ printf "\033[M\r$(1)" >&2;
+ endef
+endif
+
+define dumpinfo
@mkdir -p tmp
- @echo Collecting package info...
- @-for dir in package/*/; do \
+ @echo -n Collecting package info...
+ @-for dir in $(1)/*/; do \
[ -f "$${dir}/Makefile" ] || continue; \
+ $(call progress,Collecting package info... $${dir%%/}) \
echo Source-Makefile: $${dir}Makefile; \
$(NO_TRACE_MAKE) --no-print-dir DUMP=1 -C $$dir 3>/dev/null || echo "ERROR: please fix $${dir}Makefile" >&2; \
echo; \
done > $@
+ $(call progress,Collecting package info... done)
+ echo
+endef
+
+tmp/.pkginfo:
+ $(call dumpinfo,package)
tmp/.targetinfo:
- @mkdir -p tmp
- @echo Collecting target info...
- @-for dir in target/linux/*/; do \
- [ -f "$${dir}/Makefile" ] || continue; \
- ( cd "$$dir"; $(NO_TRACE_MAKE) --no-print-dir DUMP=1 3>/dev/null || echo "ERROR: please fix $${dir}Makefile" >&2 ); \
- echo; \
- done > $@
+ $(call dumpinfo,target/linux)
tmpinfo-clean: FORCE
@-rm -rf tmp/.pkginfo tmp/.targetinfo