summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorRalph Hempel <ralph.hempel@lantiq.com>2008-03-20 17:08:24 +0000
committerRalph Hempel <ralph.hempel@lantiq.com>2008-03-20 17:08:24 +0000
commit585997f8d2cb0c080a9f9d6f158dcefe55f9ad12 (patch)
tree88947f6291ed9967c21833c5b5ac8d1e0f38ad70 /Makefile
parent2b5f3d64a358aaf3d26642c718f44a428cfdf2fa (diff)
downloadmaster-31e0f0ae-585997f8d2cb0c080a9f9d6f158dcefe55f9ad12.tar.gz
master-31e0f0ae-585997f8d2cb0c080a9f9d6f158dcefe55f9ad12.tar.bz2
master-31e0f0ae-585997f8d2cb0c080a9f9d6f158dcefe55f9ad12.zip
fix package/symlinks target, will call scripts/feeds update / install introduce new package/symlinks-install and package/symlinks-clean targets - package/symlink-install will re-create the index files and the symlinks for all ./feeds (no update from repositories is performed) - package/symlink-clean will delete all installed symlinks (keeping the ./feeds untouched)
SVN-Revision: 10634
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile16
1 files changed, 13 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 77660bb8d7..8b0ef0d57d 100644
--- a/Makefile
+++ b/Makefile
@@ -57,10 +57,20 @@ prepare: .config $(tools/stamp-install) $(toolchain/stamp-install)
world: prepare $(target/stamp-compile) $(package/stamp-cleanup) $(package/stamp-compile) $(package/stamp-install) $(package/stamp-rootfs-prepare) $(target/stamp-install) FORCE
$(MAKE) package/index
+# update all feeds, re-create index files, install symlinks
package/symlinks:
- $(SCRIPT_DIR)/feeds update
- cd package; ln -sf ../feeds/packages openwrt-packages
+ $(SCRIPT_DIR)/feeds update -a
+ $(SCRIPT_DIR)/feeds install -a
-.PHONY: clean dirclean prereq prepare world package/symlinks
+# re-create index files, install symlinks
+package/symlinks-install:
+ $(SCRIPT_DIR)/feeds update -i
+ $(SCRIPT_DIR)/feeds install -a
+
+# remove all symlinks, don't touch ./feeds
+package/symlinks-clean:
+ $(SCRIPT_DIR)/feeds uninstall -a
+
+.PHONY: clean dirclean prereq prepare world package/symlinks package/symlinks-install package/symlinks-clean
endif