summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-09-15 08:53:23 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-09-15 08:53:23 +0000
commit53a1d55b347258192dd8ae20337076ff669ed3cd (patch)
tree1ddf224f0243c5d6d7634350e1776d97f75ffcac /Makefile
parent72d4000d5477fad3e6e9e6b36659f995c585f029 (diff)
downloadmaster-31e0f0ae-53a1d55b347258192dd8ae20337076ff669ed3cd.tar.gz
master-31e0f0ae-53a1d55b347258192dd8ae20337076ff669ed3cd.tar.bz2
master-31e0f0ae-53a1d55b347258192dd8ae20337076ff669ed3cd.zip
add 'make prepare' target for building the tools and toolchain
SVN-Revision: 8780
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 48a138db15..dcd5bae72e 100644
--- a/Makefile
+++ b/Makefile
@@ -50,10 +50,13 @@ dirclean: clean
# check prerequisites before starting to build
prereq: $(package/stamp-prereq) $(target/stamp-prereq) ;
-world: .config $(tools/stamp-install) $(toolchain/stamp-install) $(target/stamp-compile) $(package/stamp-cleanup) $(package/stamp-compile) $(package/stamp-install) $(package/stamp-rootfs-prepare) $(target/stamp-install) FORCE
+prepare: .config $(tools/stamp-install) $(toolchain/stamp-install)
+world: prepare $(target/stamp-compile) $(package/stamp-cleanup) $(package/stamp-compile) $(package/stamp-install) $(package/stamp-rootfs-prepare) $(target/stamp-install) FORCE
$(MAKE) package/index
package/symlinks:
$(SCRIPT_DIR)/feeds.sh $(CONFIG_SOURCE_FEEDS) $(CONFIG_SOURCE_FEEDS_REV)
+.PHONY: clean dirclean prereq prepare world package/symlinks
+
endif