summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-02-27 21:14:00 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-02-27 21:14:00 +0000
commit423e90915d930f680ffec4eb5157696deaac35ba (patch)
tree5a8a4e4f5cfbcd04c7c205af37e898bbc2e799ff /Makefile
parent046dc6bde1ddd41fee5b9c196f85fe28de2400fb (diff)
downloadmaster-31e0f0ae-423e90915d930f680ffec4eb5157696deaac35ba.tar.gz
master-31e0f0ae-423e90915d930f680ffec4eb5157696deaac35ba.tar.bz2
master-31e0f0ae-423e90915d930f680ffec4eb5157696deaac35ba.zip
Massive speedup in the package/target scanning step - per package metadata files are now cached. - timestamp.pl calls have been replaced with make file dependencies - an extra stamp file ensures that directory listing changes force a rebuild
SVN-Revision: 6404
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile59
1 files changed, 27 insertions, 32 deletions
diff --git a/Makefile b/Makefile
index fea8ed3162..d9db23678d 100644
--- a/Makefile
+++ b/Makefile
@@ -39,44 +39,37 @@ else
endif
export OPENWRTVERSION
-ifneq ($(shell ./scripts/timestamp.pl -p tmp/.pkginfo package scripts include),tmp/.pkginfo)
- tmp/.pkginfo: FORCE
-endif
-
-ifneq ($(shell ./scripts/timestamp.pl -p tmp/.targetinfo target/linux scripts include),tmp/.targetinfo)
- tmp/.targetinfo: FORCE
-endif
-
ifeq ($(FORCE),)
.config scripts/config/conf scripts/config/mconf: tmp/.prereq-build
world: tmp/.prereq-packages tmp/.prereq-target
endif
-ifeq ($(IS_TTY),1)
- define progress
- printf "\033[M\r$(1)" >&2;
- endef
-endif
-
-define dumpinfo
- @mkdir -p tmp
- @echo -n Collecting $(2) info...
- @-for dir in $(1)/*/; do \
- [ -f "$${dir}/Makefile" ] || continue; \
- $(call progress,Collecting $(2) info: $${dir%%/}) \
- echo Source-Makefile: $${dir}Makefile; \
- $(NO_TRACE_MAKE) --no-print-dir DUMP=1 -C $$dir 3>/dev/null || echo "ERROR: please fix $${dir}Makefile" >&2; \
- echo; \
- done > $@
- @($(call progress,Collecting $(2) info: done))
- @echo
+define stamp
+tmp/info/.stamp-$(1)-$(shell ls $(2)/*/Makefile | (md5sum || md5) 2>/dev/null | cut -d' ' -f1)
endef
-tmp/.pkginfo:
- $(call dumpinfo,package,package)
+STAMP_pkginfo=$(call stamp,pkginfo,package)
+STAMP_targetinfo=$(call stamp,targetinfo,target/linux)
+define scan_info
+
+$(STAMP_$(1)):
+ @mkdir -p tmp/info
+ @rm -f tmp/info/.stamp-$(1)*
+ @touch $$@
+
+$(foreach FILE,$(shell ls $(2)/*/Makefile),
+tmp/.$(1): $(FILE)
+$(FILE):
+)
+
+tmp/.$(1): $(STAMP_$(1))
+ @echo -n Collecting $(3) info...
+ @$(NO_TRACE_MAKE) -s -f include/scan.mk SCAN_TARGET="$(1)" SCAN_DIR="$(2)" SCAN_NAME="$(3)" SCAN_DEPS="$(4)"
+
+endef
-tmp/.targetinfo:
- $(call dumpinfo,target/linux,target)
+$(eval $(call scan_info,pkginfo,package,package,include/package.mk))
+$(eval $(call scan_info,targetinfo,target/linux,target,include/kernel-build.mk include/kernel-version.mk))
tmpinfo-clean: FORCE
@-rm -rf tmp/.pkginfo tmp/.targetinfo
@@ -117,10 +110,12 @@ kernel_menuconfig: .config FORCE
-$(MAKE) target/linux-prepare
$(NO_TRACE_MAKE) -C target/linux menuconfig
-package/%: tmp/.pkginfo tmp/.targetinfo FORCE
+package/%:
+ @$(NO_TRACE_MAKE) -s tmp/.pkginfo tmp/.targetinfo
$(MAKE) -C package $(patsubst package/%,%,$@)
-target/%: tmp/.pkginfo tmp/.targetinfo FORCE
+target/%:
+ @$(NO_TRACE_MAKE) -s tmp/.pkginfo tmp/.targetinfo
$(MAKE) -C target $(patsubst target/%,%,$@)
tools/%: FORCE