summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2016-07-26 15:05:35 +0200
committerJo-Philipp Wich <jo@mein.io>2016-08-01 18:11:21 +0200
commit27854a0a84cd2db9539b662a1f1fc95ef7409962 (patch)
tree445387e09212e6741a19c284c65d5c96e6d91b6a /Makefile
parent4d9fc1bd44e9012de7452c6ec1fe7ca9d098f3dd (diff)
downloadmaster-31e0f0ae-27854a0a84cd2db9539b662a1f1fc95ef7409962.tar.gz
master-31e0f0ae-27854a0a84cd2db9539b662a1f1fc95ef7409962.tar.bz2
master-31e0f0ae-27854a0a84cd2db9539b662a1f1fc95ef7409962.zip
build: add checksum target
Add a new "checksum" make target which generates an sha256sums file over the image files produced in bin/targets/ and automatically call it during make world after the package index generation. The advantage of this new target is that it is guaranteed to run after the images, the SDK and the ImageBuilder archives have been generated to ensure that they all end up in the checksum file. Fixes FS#51. Uses sed to postprocess the OpenSSL digest output into an sha256sum command compatible format. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index c3e1ed7707..5bd4fb2ca7 100644
--- a/Makefile
+++ b/Makefile
@@ -83,9 +83,13 @@ prereq: $(target/stamp-prereq) tmp/.prereq_packages
exit 1; \
fi
+checksum: FORCE
+ $(call sha256sums,$(BIN_DIR))
+
prepare: .config $(tools/stamp-install) $(toolchain/stamp-install)
world: prepare $(target/stamp-compile) $(package/stamp-compile) $(package/stamp-install) $(target/stamp-install) FORCE
$(_SINGLE)$(SUBMAKE) -r package/index
+ $(_SINGLE)$(SUBMAKE) -r checksum
.PHONY: clean dirclean prereq prepare world package/symlinks package/symlinks-install package/symlinks-clean