summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-03-04 21:07:29 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-03-04 21:07:29 +0000
commit08c5cb8c23540d2573e185a92358e6a358603c03 (patch)
treed03625ced36706ad03dbd62c3e7fc2ca8ad90306 /Makefile
parentaabda0f133ce61531c4951ccc1c21381e3748cbb (diff)
downloadmaster-31e0f0ae-08c5cb8c23540d2573e185a92358e6a358603c03.tar.gz
master-31e0f0ae-08c5cb8c23540d2573e185a92358e6a358603c03.tar.bz2
master-31e0f0ae-08c5cb8c23540d2573e185a92358e6a358603c03.zip
fix metadata scan for profile split
SVN-Revision: 6515
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index 25f2f4eb21..f6d4fff3ab 100644
--- a/Makefile
+++ b/Makefile
@@ -45,7 +45,7 @@ ifeq ($(FORCE),)
endif
define stamp
-tmp/info/.stamp-$(1)-$(shell ls $(2)/*/Makefile | (md5sum || md5) 2>/dev/null | cut -d' ' -f1)
+tmp/info/.stamp-$(1)-$(shell ls $(2)/*/Makefile $(5) | (md5sum || md5) 2>/dev/null | cut -d' ' -f1)
endef
STAMP_pkginfo=$(call stamp,pkginfo,package)
@@ -57,19 +57,23 @@ $(STAMP_$(1)):
@rm -f tmp/info/.stamp-$(1)*
@touch $$@
-$(foreach FILE,$(shell ls $(2)/*/Makefile),
+$(foreach FILE,$(shell ls $(2)/*/Makefile $(5)),
tmp/.$(1): $(FILE)
$(FILE):
)
+ifneq ($(5),)
+tmp/.$(1): $(shell ls $(5))
+endif
+
tmp/.$(1): $(STAMP_$(1)) $(4)
@echo -n Collecting $(3) info...
- @$(NO_TRACE_MAKE) -s -f include/scan.mk SCAN_TARGET="$(1)" SCAN_DIR="$(2)" SCAN_NAME="$(3)" SCAN_DEPS="$(4)"
+ @$(NO_TRACE_MAKE) -s -f include/scan.mk SCAN_TARGET="$(1)" SCAN_DIR="$(2)" SCAN_NAME="$(3)" SCAN_DEPS="$(4)" SCAN_EXTRA="$(5)"
endef
$(eval $(call scan_info,pkginfo,package,package,include/package.mk))
-$(eval $(call scan_info,targetinfo,target/linux,target,include/kernel-build.mk include/kernel-version.mk))
+$(eval $(call scan_info,targetinfo,target/linux,target,include/kernel-build.mk include/kernel-version.mk,target/linux/*/profiles/*.mk))
tmpinfo-clean: FORCE
@-rm -rf tmp/.pkginfo tmp/.targetinfo