summaryrefslogtreecommitdiffstats
path: root/Config.in
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2013-06-27 19:58:35 +0000
committerFlorian Fainelli <florian@openwrt.org>2013-06-27 19:58:35 +0000
commitf5a0a578f8ccf7df7a742bb0fcf16b7161fad393 (patch)
tree3f3782e219d726a938b2596b8c6ae2d55befb6db /Config.in
parent6a4f2922f6303a006d66b4bbb79541823b1c12b4 (diff)
downloadmaster-31e0f0ae-f5a0a578f8ccf7df7a742bb0fcf16b7161fad393.tar.gz
master-31e0f0ae-f5a0a578f8ccf7df7a742bb0fcf16b7161fad393.tar.bz2
master-31e0f0ae-f5a0a578f8ccf7df7a742bb0fcf16b7161fad393.zip
include/image.mk: do not make initramfs build exclusive
Allow building initramfs along with other types of filesystems. Signed-off-by: Florian Fainelli <florian@openwrt.org> SVN-Revision: 37050
Diffstat (limited to 'Config.in')
-rw-r--r--Config.in8
1 files changed, 2 insertions, 6 deletions
diff --git a/Config.in b/Config.in
index 8dd73cc258..98e3e046f9 100644
--- a/Config.in
+++ b/Config.in
@@ -78,7 +78,6 @@ menu "Target Images"
config TARGET_ROOTFS_EXT4FS
bool "ext4"
default y if USES_EXT4
- depends on !TARGET_ROOTFS_INITRAMFS
help
Ext4 file system with some free space for uml images
@@ -86,35 +85,32 @@ menu "Target Images"
bool "iso"
default n
depends on TARGET_x86_generic
- depends on !TARGET_ROOTFS_INITRAMFS
help
Create some bootable ISO image
config TARGET_ROOTFS_JFFS2
bool "jffs2"
default y if USES_JFFS2
- depends on !TARGET_ROOTFS_INITRAMFS
help
Build a jffs2 root filesystem
config TARGET_ROOTFS_JFFS2_NAND
bool "jffs2 for NAND"
default y if USES_JFFS2_NAND
- depends on !TARGET_ROOTFS_INITRAMFS && USES_JFFS2_NAND
+ depends on USES_JFFS2_NAND
help
Build a jffs2 root filesystem for NAND flash
config TARGET_ROOTFS_SQUASHFS
bool "squashfs"
default y if USES_SQUASHFS
- depends on !TARGET_ROOTFS_INITRAMFS
help
Build a squashfs-lzma root filesystem
config TARGET_ROOTFS_UBIFS
bool "ubifs"
default y if USES_UBIFS
- depends on !TARGET_ROOTFS_INITRAMFS && USES_UBIFS
+ depends on USES_UBIFS
help
Build a ubifs root filesystem