summaryrefslogtreecommitdiffstats
path: root/Config.in
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2013-10-23 22:16:10 +0000
committerLuka Perkov <luka@openwrt.org>2013-10-23 22:16:10 +0000
commit0c5c12a042bbea9cc718e139f14eb98550da6028 (patch)
tree8fc21f082372e106f02a6ec7dc9fe67f2e96ec6b /Config.in
parent7938d1645165192abaaf4e4cdbe0bbb880ec3a9c (diff)
downloadmaster-31e0f0ae-0c5c12a042bbea9cc718e139f14eb98550da6028.tar.gz
master-31e0f0ae-0c5c12a042bbea9cc718e139f14eb98550da6028.tar.bz2
master-31e0f0ae-0c5c12a042bbea9cc718e139f14eb98550da6028.zip
Config.in: add more options when it comes to including kernel image into rootfs
Signed-off-by: Luka Perkov <luka@openwrt.org> SVN-Revision: 38517
Diffstat (limited to 'Config.in')
-rw-r--r--Config.in26
1 files changed, 25 insertions, 1 deletions
diff --git a/Config.in b/Config.in
index a7ef477b20..38d11eb281 100644
--- a/Config.in
+++ b/Config.in
@@ -173,7 +173,7 @@ menu "Target Images"
help
Allows you to change the percentage of reserved blocks in the root filesystem
- config TARGET_ROOTFS_INCLUDE_KERNEL
+ menuconfig TARGET_ROOTFS_INCLUDE_KERNEL
bool "Include kernel in root filesystem"
depends on TARGET_ROOTFS_UBIFS || TARGET_ROOTFS_EXT4FS
default n if USES_UBIFS
@@ -181,6 +181,30 @@ menu "Target Images"
Include the kernel image in the rootfs. Typically the image is placed
below /boot.
+ config TARGET_ROOTFS_INCLUDE_UIMAGE
+ bool "include uImage" if TARGET_ROOTFS_INCLUDE_KERNEL
+ default y
+ help
+ This option might not apply to all targets. Make sure
+ to check target/linux/<your_target>/image/Makefile to
+ see if this option will have any effect.
+
+ config TARGET_ROOTFS_INCLUDE_ZIMAGE
+ bool "include zImage" if TARGET_ROOTFS_INCLUDE_KERNEL
+ default y
+ help
+ This option might not apply to all targets. Make sure
+ to check target/linux/<your_target>/image/Makefile to
+ see if this option will have any effect.
+
+ config TARGET_ROOTFS_INCLUDE_FIT
+ bool "include FIT" if TARGET_ROOTFS_INCLUDE_KERNEL
+ default y
+ help
+ This option might not apply to all targets. Make sure
+ to check target/linux/<your_target>/image/Makefile to
+ see if this option will have any effect.
+
config TARGET_ROOTFS_INCLUDE_DTB
bool "Include DTB in root filesystem"
depends on TARGET_ROOTFS_UBIFS || TARGET_ROOTFS_EXT4FS