summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2008-05-19 08:46:35 +0000
committerGabor Juhos <juhosg@openwrt.org>2008-05-19 08:46:35 +0000
commitf40178918715dae3e42ecb7cb69f2f50819e6826 (patch)
tree3e3971e6ff14bf09549a4c0e481bbcfd912ab923
parentac897ce5b14360d98e82958b41cab904c2157985 (diff)
downloadmaster-31e0f0ae-f40178918715dae3e42ecb7cb69f2f50819e6826.tar.gz
master-31e0f0ae-f40178918715dae3e42ecb7cb69f2f50819e6826.tar.bz2
master-31e0f0ae-f40178918715dae3e42ecb7cb69f2f50819e6826.zip
refresh kernel patches
SVN-Revision: 11202
-rw-r--r--target/linux/ifxmips/patches/100-board.patch32
-rw-r--r--target/linux/ifxmips/patches/110-drivers.patch48
-rw-r--r--target/linux/ifxmips/patches/160-cfi-swap.patch9
3 files changed, 44 insertions, 45 deletions
diff --git a/target/linux/ifxmips/patches/100-board.patch b/target/linux/ifxmips/patches/100-board.patch
index a4d3e4308e..0608f8ab33 100644
--- a/target/linux/ifxmips/patches/100-board.patch
+++ b/target/linux/ifxmips/patches/100-board.patch
@@ -1,8 +1,8 @@
-Index: linux-2.6.25.1/arch/mips/Kconfig
+Index: linux-2.6.25.4/arch/mips/Kconfig
===================================================================
---- linux-2.6.25.1.orig/arch/mips/Kconfig 2008-05-10 01:14:39.000000000 +0100
-+++ linux-2.6.25.1/arch/mips/Kconfig 2008-05-10 01:29:54.000000000 +0100
-@@ -78,6 +78,19 @@
+--- linux-2.6.25.4.orig/arch/mips/Kconfig
++++ linux-2.6.25.4/arch/mips/Kconfig
+@@ -78,6 +78,19 @@ config MIPS_COBALT
select SYS_SUPPORTS_LITTLE_ENDIAN
select GENERIC_HARDIRQS_NO__DO_IRQ
@@ -22,7 +22,7 @@ Index: linux-2.6.25.1/arch/mips/Kconfig
config MACH_DECSTATION
bool "DECstations"
select BOOT_ELF32
-@@ -693,6 +706,7 @@
+@@ -693,6 +706,7 @@ source "arch/mips/sibyte/Kconfig"
source "arch/mips/tx4927/Kconfig"
source "arch/mips/tx4938/Kconfig"
source "arch/mips/vr41xx/Kconfig"
@@ -30,11 +30,11 @@ Index: linux-2.6.25.1/arch/mips/Kconfig
endmenu
-Index: linux-2.6.25.1/arch/mips/Makefile
+Index: linux-2.6.25.4/arch/mips/Makefile
===================================================================
---- linux-2.6.25.1.orig/arch/mips/Makefile 2008-05-10 01:14:49.000000000 +0100
-+++ linux-2.6.25.1/arch/mips/Makefile 2008-05-10 01:14:49.000000000 +0100
-@@ -282,6 +282,13 @@
+--- linux-2.6.25.4.orig/arch/mips/Makefile
++++ linux-2.6.25.4/arch/mips/Makefile
+@@ -282,6 +282,13 @@ core-$(CONFIG_MIPS_COBALT) += arch/mips/
cflags-$(CONFIG_MIPS_COBALT) += -Iinclude/asm-mips/mach-cobalt
load-$(CONFIG_MIPS_COBALT) += 0xffffffff80080000
@@ -48,10 +48,10 @@ Index: linux-2.6.25.1/arch/mips/Makefile
#
# DECstation family
#
-Index: linux-2.6.25.1/include/asm-mips/bootinfo.h
+Index: linux-2.6.25.4/include/asm-mips/bootinfo.h
===================================================================
---- linux-2.6.25.1.orig/include/asm-mips/bootinfo.h 2008-05-10 01:14:39.000000000 +0100
-+++ linux-2.6.25.1/include/asm-mips/bootinfo.h 2008-05-10 01:14:49.000000000 +0100
+--- linux-2.6.25.4.orig/include/asm-mips/bootinfo.h
++++ linux-2.6.25.4/include/asm-mips/bootinfo.h
@@ -94,6 +94,12 @@
#define MACH_MSP7120_FPGA 5 /* PMC-Sierra MSP7120 Emulation */
#define MACH_MSP_OTHER 255 /* PMC-Sierra unknown board type */
@@ -65,11 +65,11 @@ Index: linux-2.6.25.1/include/asm-mips/bootinfo.h
#define CL_SIZE COMMAND_LINE_SIZE
extern char *system_type;
-Index: linux-2.6.25.1/arch/mips/kernel/traps.c
+Index: linux-2.6.25.4/arch/mips/kernel/traps.c
===================================================================
---- linux-2.6.25.1.orig/arch/mips/kernel/traps.c 2008-05-10 01:14:39.000000000 +0100
-+++ linux-2.6.25.1/arch/mips/kernel/traps.c 2008-05-10 01:14:49.000000000 +0100
-@@ -1379,6 +1379,7 @@
+--- linux-2.6.25.4.orig/arch/mips/kernel/traps.c
++++ linux-2.6.25.4/arch/mips/kernel/traps.c
+@@ -1379,6 +1379,7 @@ void __cpuinit per_cpu_trap_init(void)
*/
if (cpu_has_mips_r2) {
cp0_compare_irq = (read_c0_intctl() >> 29) & 7;
diff --git a/target/linux/ifxmips/patches/110-drivers.patch b/target/linux/ifxmips/patches/110-drivers.patch
index 9ce88f2325..64bb6cee31 100644
--- a/target/linux/ifxmips/patches/110-drivers.patch
+++ b/target/linux/ifxmips/patches/110-drivers.patch
@@ -1,8 +1,8 @@
-Index: linux-2.6.25/drivers/char/Makefile
+Index: linux-2.6.25.4/drivers/char/Makefile
===================================================================
---- linux-2.6.25.orig/drivers/char/Makefile 2008-05-07 18:58:25.000000000 +0100
-+++ linux-2.6.25/drivers/char/Makefile 2008-05-07 18:58:42.000000000 +0100
-@@ -112,6 +112,12 @@
+--- linux-2.6.25.4.orig/drivers/char/Makefile
++++ linux-2.6.25.4/drivers/char/Makefile
+@@ -112,6 +112,12 @@ obj-$(CONFIG_PS3_FLASH) += ps3flash.o
obj-$(CONFIG_JS_RTC) += js-rtc.o
js-rtc-y = rtc.o
@@ -15,20 +15,20 @@ Index: linux-2.6.25/drivers/char/Makefile
# Files generated that shall be removed upon make clean
clean-files := consolemap_deftbl.c defkeymap.c
-Index: linux-2.6.25/drivers/mtd/maps/Makefile
+Index: linux-2.6.25.4/drivers/mtd/maps/Makefile
===================================================================
---- linux-2.6.25.orig/drivers/mtd/maps/Makefile 2008-05-07 18:58:25.000000000 +0100
-+++ linux-2.6.25/drivers/mtd/maps/Makefile 2008-05-07 18:58:42.000000000 +0100
-@@ -68,3 +68,4 @@
+--- linux-2.6.25.4.orig/drivers/mtd/maps/Makefile
++++ linux-2.6.25.4/drivers/mtd/maps/Makefile
+@@ -68,3 +68,4 @@ obj-$(CONFIG_MTD_PLATRAM) += plat-ram.o
obj-$(CONFIG_MTD_OMAP_NOR) += omap_nor.o
obj-$(CONFIG_MTD_MTX1) += mtx-1_flash.o
obj-$(CONFIG_MTD_INTEL_VR_NOR) += intel_vr_nor.o
+obj-$(CONFIG_MTD_IFXMIPS) += ifxmips.o
-Index: linux-2.6.25/drivers/net/Kconfig
+Index: linux-2.6.25.4/drivers/net/Kconfig
===================================================================
---- linux-2.6.25.orig/drivers/net/Kconfig 2008-05-07 18:58:41.000000000 +0100
-+++ linux-2.6.25/drivers/net/Kconfig 2008-05-07 18:58:42.000000000 +0100
-@@ -351,6 +351,12 @@
+--- linux-2.6.25.4.orig/drivers/net/Kconfig
++++ linux-2.6.25.4/drivers/net/Kconfig
+@@ -351,6 +351,12 @@ config MACB
source "drivers/net/arm/Kconfig"
@@ -41,11 +41,11 @@ Index: linux-2.6.25/drivers/net/Kconfig
config AX88796
tristate "ASIX AX88796 NE2000 clone support"
depends on ARM || MIPS || SUPERH
-Index: linux-2.6.25/drivers/serial/Kconfig
+Index: linux-2.6.25.4/drivers/serial/Kconfig
===================================================================
---- linux-2.6.25.orig/drivers/serial/Kconfig 2008-05-07 18:58:25.000000000 +0100
-+++ linux-2.6.25/drivers/serial/Kconfig 2008-05-08 07:53:18.000000000 +0100
-@@ -1327,6 +1327,14 @@
+--- linux-2.6.25.4.orig/drivers/serial/Kconfig
++++ linux-2.6.25.4/drivers/serial/Kconfig
+@@ -1327,6 +1327,14 @@ config SERIAL_OF_PLATFORM
Currently, only 8250 compatible ports are supported, but
others can easily be added.
@@ -60,21 +60,21 @@ Index: linux-2.6.25/drivers/serial/Kconfig
config SERIAL_QE
tristate "Freescale QUICC Engine serial port support"
depends on QUICC_ENGINE
-Index: linux-2.6.25/drivers/serial/Makefile
+Index: linux-2.6.25.4/drivers/serial/Makefile
===================================================================
---- linux-2.6.25.orig/drivers/serial/Makefile 2008-05-07 18:58:25.000000000 +0100
-+++ linux-2.6.25/drivers/serial/Makefile 2008-05-07 18:58:42.000000000 +0100
-@@ -66,4 +66,5 @@
+--- linux-2.6.25.4.orig/drivers/serial/Makefile
++++ linux-2.6.25.4/drivers/serial/Makefile
+@@ -66,4 +66,5 @@ obj-$(CONFIG_SERIAL_UARTLITE) += uartlit
obj-$(CONFIG_SERIAL_NETX) += netx-serial.o
obj-$(CONFIG_SERIAL_OF_PLATFORM) += of_serial.o
obj-$(CONFIG_SERIAL_KS8695) += serial_ks8695.o
+obj-$(CONFIG_SERIAL_IFXMIPS) += ifxmips_asc.o
obj-$(CONFIG_SERIAL_QE) += ucc_uart.o
-Index: linux-2.6.25/drivers/watchdog/Makefile
+Index: linux-2.6.25.4/drivers/watchdog/Makefile
===================================================================
---- linux-2.6.25.orig/drivers/watchdog/Makefile 2008-05-07 18:58:25.000000000 +0100
-+++ linux-2.6.25/drivers/watchdog/Makefile 2008-05-07 18:58:42.000000000 +0100
-@@ -96,6 +96,7 @@
+--- linux-2.6.25.4.orig/drivers/watchdog/Makefile
++++ linux-2.6.25.4/drivers/watchdog/Makefile
+@@ -96,6 +96,7 @@ obj-$(CONFIG_WDT_RM9K_GPI) += rm9k_wdt.o
obj-$(CONFIG_SIBYTE_WDOG) += sb_wdog.o
obj-$(CONFIG_AR7_WDT) += ar7_wdt.o
obj-$(CONFIG_TXX9_WDT) += txx9wdt.o
diff --git a/target/linux/ifxmips/patches/160-cfi-swap.patch b/target/linux/ifxmips/patches/160-cfi-swap.patch
index 6ddfc7e233..cf749be10d 100644
--- a/target/linux/ifxmips/patches/160-cfi-swap.patch
+++ b/target/linux/ifxmips/patches/160-cfi-swap.patch
@@ -1,8 +1,8 @@
-Index: linux-2.6.25/drivers/mtd/chips/cfi_cmdset_0002.c
+Index: linux-2.6.25.4/drivers/mtd/chips/cfi_cmdset_0002.c
===================================================================
---- linux-2.6.25.orig/drivers/mtd/chips/cfi_cmdset_0002.c 2008-05-07 18:58:41.000000000 +0100
-+++ linux-2.6.25/drivers/mtd/chips/cfi_cmdset_0002.c 2008-05-07 18:58:42.000000000 +0100
-@@ -1015,7 +1015,9 @@
+--- linux-2.6.25.4.orig/drivers/mtd/chips/cfi_cmdset_0002.c
++++ linux-2.6.25.4/drivers/mtd/chips/cfi_cmdset_0002.c
+@@ -1015,7 +1015,9 @@ static int __xipram do_write_oneword(str
int retry_cnt = 0;
adr += chip->start;
@@ -13,4 +13,3 @@ Index: linux-2.6.25/drivers/mtd/chips/cfi_cmdset_0002.c
spin_lock(chip->mutex);
ret = get_chip(map, chip, adr, FL_WRITING);
if (ret) {
-