summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Crispin <john@phrozen.org>2016-05-11 12:54:41 +0200
committerJohn Crispin <john@phrozen.org>2016-05-12 03:29:36 +0200
commitecbaaa401a98c7bf94e3e06373fea414c7a27d3e (patch)
tree8fe14ad55d187667305ddd5f1d99ec8e3f78cb28
parent0f12f329966e064bd0eda38f36d1a1c0bf25693f (diff)
downloadmaster-31e0f0ae-ecbaaa401a98c7bf94e3e06373fea414c7a27d3e.tar.gz
master-31e0f0ae-ecbaaa401a98c7bf94e3e06373fea414c7a27d3e.tar.bz2
master-31e0f0ae-ecbaaa401a98c7bf94e3e06373fea414c7a27d3e.zip
ramips: convert mt7688 to new image building code
Signed-off-by: John Crispin <john@phrozen.org>
-rw-r--r--target/linux/ramips/image/mt7688.mk18
-rw-r--r--target/linux/ramips/mt7688/profiles/00-default.mk4
-rw-r--r--target/linux/ramips/mt7688/profiles/01-mediatek.mk18
3 files changed, 14 insertions, 26 deletions
diff --git a/target/linux/ramips/image/mt7688.mk b/target/linux/ramips/image/mt7688.mk
index 45991d0874..b3860ef78a 100644
--- a/target/linux/ramips/image/mt7688.mk
+++ b/target/linux/ramips/image/mt7688.mk
@@ -2,10 +2,18 @@
# MT7688 Profiles
#
-Image/Build/Profile/LinkIt7688=$(call BuildFirmware/Default32M/$(1),$(1),LinkIt7688,LINKIT7688)
-Image/Build/Profile/WRTNODE2R=$(call BuildFirmware/Default16M/$(1),$(1),wrtnode2r,WRTNODE2R)
+define Device/LinkIt7688
+ DTS := LINKIT7688
+ IMAGE_SIZE := $(ralink_default_fw_size_32M)
+ DEVICE_TITLE := MediaTek LinkIt Smart 7688
+ DEVICE_PACKAGES:= kmod-usb2 kmod-usb-ohci uboot-envtools
+endef
+TARGET_DEVICES += LinkIt7688
-define Image/Build/Profile/Default
- $(call Image/Build/Profile/LinkIt7688,$(1))
- $(call Image/Build/Profile/WRTNODE2R,$(1))
+define Device/wrtnode2r
+ DTS := WRTNODE2R
+ IMAGE_SIZE := $(ralink_default_fw_size_16M)
+ DEVICE_TITLE := WRTnode 2R
+ DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci
endef
+TARGET_DEVICES += wrtnode2r
diff --git a/target/linux/ramips/mt7688/profiles/00-default.mk b/target/linux/ramips/mt7688/profiles/00-default.mk
index 6c7d721444..55a85a69e9 100644
--- a/target/linux/ramips/mt7688/profiles/00-default.mk
+++ b/target/linux/ramips/mt7688/profiles/00-default.mk
@@ -7,9 +7,7 @@
define Profile/Default
NAME:=Default Profile
- PACKAGES:=\
- kmod-usb-core kmod-usb2 kmod-usb-ohci \
- kmod-ledtrig-usbdev
+ PACKAGES:= kmod-usb-core kmod-usb2 kmod-usb-ohci kmod-ledtrig-usbdev
endef
define Profile/Default/Description
diff --git a/target/linux/ramips/mt7688/profiles/01-mediatek.mk b/target/linux/ramips/mt7688/profiles/01-mediatek.mk
deleted file mode 100644
index 1ef824dba6..0000000000
--- a/target/linux/ramips/mt7688/profiles/01-mediatek.mk
+++ /dev/null
@@ -1,18 +0,0 @@
-#
-# Copyright (C) 2015 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/LinkIt7688
- NAME:=LinkIt7688
- PACKAGES:=\
- kmod-usb-core kmod-usb2 kmod-usb-ohci \
- uboot-envtools kmod-ledtrig-netdev
-endef
-
-define Profile/LinkIt7688/Description
- Default package set compatible with LinkIt Smart7688 dev board.
-endef
-$(eval $(call Profile,LinkIt7688))