summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-01-22 09:35:12 +0000
committerJohn Crispin <john@openwrt.org>2015-01-22 09:35:12 +0000
commitdeb66a555e8856d253a5feb6620ae4d50f404e69 (patch)
treeeb6efc148ec701d85c816c92ea98510cabdc8480
parentac5ede7116143af70b03be4624b26081574054d8 (diff)
downloadmaster-31e0f0ae-deb66a555e8856d253a5feb6620ae4d50f404e69.tar.gz
master-31e0f0ae-deb66a555e8856d253a5feb6620ae4d50f404e69.tar.bz2
master-31e0f0ae-deb66a555e8856d253a5feb6620ae4d50f404e69.zip
ramips: improve and fix Memory 2 Move support
This patch is a follow up for my previous patch: "ramips: add support for Intenso Memory 2 Move USB 3.0". It fixes a couple of errors in the DTS (one of which broke the gpio-buttons). The kmod-leds-gpio dependency has been dropped as it is already part of the ramips target. Furthermore the ramdisk/uImage image is generated by default for the rt3050 subtarget. This image is needed to flash OpenWrt for the first time onto the device via TFTP. Signed-off-by: Christian Lamparter <chunkeey@googlemail.com> SVN-Revision: 44072
-rw-r--r--target/linux/ramips/dts/M2M.dts28
-rw-r--r--target/linux/ramips/rt305x/profiles/m2m.mk2
-rw-r--r--target/linux/ramips/rt305x/target.mk2
3 files changed, 13 insertions, 19 deletions
diff --git a/target/linux/ramips/dts/M2M.dts b/target/linux/ramips/dts/M2M.dts
index aa98991ae1..41910374c9 100644
--- a/target/linux/ramips/dts/M2M.dts
+++ b/target/linux/ramips/dts/M2M.dts
@@ -7,14 +7,10 @@
model = "Intenso Memory 2 Move";
chosen {
- bootargs = "console=ttyS1,57600n8 root=/dev/mtdblock5";
+ bootargs = "console=ttyS0,57600n8 root=/dev/mtdblock5";
};
palmbus@10000000 {
- uart@500 {
- status = "okay";
- };
-
spi@b00 {
status = "okay";
m25p80@0 {
@@ -54,7 +50,7 @@
pinctrl {
state_default: pinctrl0 {
gpio {
- ralink,group = "i2c", "jtag", "uartf";
+ ralink,group = "i2c", "uartf";
ralink,function = "gpio";
};
};
@@ -73,21 +69,19 @@
};
gpio-keys-polled {
- gpio-keys-polled {
compatible = "gpio-keys-polled";
#address-cells = <1>;
#size-cells = <0>;
poll-interval = <20>;
- power {
- label = "power";
- gpios = <&gpio0 1 1>;
- linux,code = <0x116>;
- };
- reset {
- label = "reset";
- gpios = <&gpio0 10 1>;
- linux,code = <0x198>;
- };
+ power {
+ label = "power";
+ gpios = <&gpio0 1 1>;
+ linux,code = <0x116>;
+ };
+ reset {
+ label = "reset";
+ gpios = <&gpio0 10 1>;
+ linux,code = <0x198>;
};
};
diff --git a/target/linux/ramips/rt305x/profiles/m2m.mk b/target/linux/ramips/rt305x/profiles/m2m.mk
index ea803baa25..1b13cc5068 100644
--- a/target/linux/ramips/rt305x/profiles/m2m.mk
+++ b/target/linux/ramips/rt305x/profiles/m2m.mk
@@ -8,7 +8,7 @@
define Profile/M2M
NAME:=Intenso Memory 2 Move
PACKAGES:=\
- kmod-ledtrig-netdev kmod-ledtrig-timer kmod-leds-gpio \
+ kmod-ledtrig-netdev kmod-ledtrig-timer \
kmod-usb-core kmod-usb2 kmod-usb-storage kmod-scsi-core \
kmod-fs-ext4 kmod-fs-vfat block-mount
endef
diff --git a/target/linux/ramips/rt305x/target.mk b/target/linux/ramips/rt305x/target.mk
index d0114c15c1..b97554fc7c 100644
--- a/target/linux/ramips/rt305x/target.mk
+++ b/target/linux/ramips/rt305x/target.mk
@@ -5,7 +5,7 @@
SUBTARGET:=rt305x
BOARDNAME:=RT3x5x/RT5350 based boards
ARCH_PACKAGES:=ramips_24kec
-FEATURES+=usb
+FEATURES+=usb ramdisk
CPU_TYPE:=24kec
CPU_SUBTYPE:=dsp