summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-08-05 13:55:52 +0000
committerJonas Gorski <jogo@openwrt.org>2015-08-05 13:55:52 +0000
commitdbe4173b206b4180e1ce03e545b63ab40ccb1cc1 (patch)
treee5107e4b2e3379b96a3bab6ff7abcf87f03242af
parent3368b4799b527a4179d9eac77acc90ce81125964 (diff)
downloadmaster-31e0f0ae-dbe4173b206b4180e1ce03e545b63ab40ccb1cc1.tar.gz
master-31e0f0ae-dbe4173b206b4180e1ce03e545b63ab40ccb1cc1.tar.bz2
master-31e0f0ae-dbe4173b206b4180e1ce03e545b63ab40ccb1cc1.zip
image: fix jffs2(_nand) image generation
Variables dependend on JFFS2_BLOCKSIZE and NANDBLOCK_SIZE are used for template generation, so need to be present before inclusion of image.mk in target image Makefiles. So move all declarations to before any includes. Fixes: r42878 ("image.mk: clean up and parallelize mkfs calls") Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 46564
-rw-r--r--target/linux/ar71xx/image/Makefile5
-rw-r--r--target/linux/au1000/image/Makefile5
-rw-r--r--target/linux/kirkwood/image/Makefile5
-rw-r--r--target/linux/lantiq/image/Makefile3
-rw-r--r--target/linux/mcs814x/image/Makefile5
-rw-r--r--target/linux/mvebu/image/Makefile4
-rw-r--r--target/linux/ppc44x/image/Makefile4
-rw-r--r--target/linux/xburst/image/Makefile5
8 files changed, 23 insertions, 13 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 78069b8d3d..e894d78c62 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -4,13 +4,14 @@
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
+
+JFFS2_BLOCKSIZE = 64k 128k 256k
+
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
IMAGE_PROFILE:=$(if $(PROFILE),$(PROFILE),Default)
-JFFS2_BLOCKSIZE = 64k 128k 256k
-
KERNEL_LOADADDR = 0x80060000
DEVICE_VARS += NETGEAR_KERNEL_MAGIC NETGEAR_BOARD NETGEAR_ID CMDLINE CONSOLE IMAGE_SIZE BOARDNAME LOADER_FLASH_OFFS
diff --git a/target/linux/au1000/image/Makefile b/target/linux/au1000/image/Makefile
index 3d5752930f..744e5c64e9 100644
--- a/target/linux/au1000/image/Makefile
+++ b/target/linux/au1000/image/Makefile
@@ -4,6 +4,9 @@
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
+
+JFFS2_BLOCKSIZE = 128k
+
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
@@ -11,8 +14,6 @@ LOADADDR = 0x81000000 # RAM start + 16M
KERNEL_ENTRY = 0x80100000
RAMSIZE = 0x00100000 # 1MB
-JFFS2_BLOCKSIZE = 128k
-
FLASH_KERNEL := 0xBFD00000
FLASH_FS := 0xBE000000
diff --git a/target/linux/kirkwood/image/Makefile b/target/linux/kirkwood/image/Makefile
index 8413a41ba3..019806c985 100644
--- a/target/linux/kirkwood/image/Makefile
+++ b/target/linux/kirkwood/image/Makefile
@@ -4,11 +4,12 @@
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
-include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/image.mk
NAND_BLOCKSIZE := 2048-128k
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
define sanitize_profile_name
$(shell echo $(PROFILE) | tr '[:upper:]' '[:lower:]')
endef
diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index f89df52102..cbe334cb9c 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -8,10 +8,11 @@
# boards missing since devicetree update
#EASY50712 ARV3527P
+JFFS2_BLOCKSIZE = 64k 128k 256k
+
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
-JFFS2_BLOCKSIZE = 64k 128k 256k
KDIR_TMP:=$(KDIR)/tmp
LOADER_MAKE := $(NO_TRACE_MAKE) -C lzma-loader KDIR=$(KDIR)
diff --git a/target/linux/mcs814x/image/Makefile b/target/linux/mcs814x/image/Makefile
index 4c8af97d22..017a564f09 100644
--- a/target/linux/mcs814x/image/Makefile
+++ b/target/linux/mcs814x/image/Makefile
@@ -4,6 +4,9 @@
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
+
+JFFS2_BLOCKSIZE = 128k
+
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
@@ -13,8 +16,6 @@ DTBS_DIR:=dts/
LOADADDR:=0x00008000
-JFFS2_BLOCKSIZE = 128k
-
UIMAGE:=$(BIN_DIR)/$(IMG_PREFIX)-uImage
define Image/Build/MkuImage
diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
index 461e3471a9..df75836412 100644
--- a/target/linux/mvebu/image/Makefile
+++ b/target/linux/mvebu/image/Makefile
@@ -4,12 +4,14 @@
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
+
+JFFS2_BLOCKSIZE = 128k
+
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
LOADADDR:=0x00008000
-JFFS2_BLOCKSIZE = 128k
KDIR_TMP:=$(KDIR)/tmp
diff --git a/target/linux/ppc44x/image/Makefile b/target/linux/ppc44x/image/Makefile
index b0513af788..e2303f6e78 100644
--- a/target/linux/ppc44x/image/Makefile
+++ b/target/linux/ppc44x/image/Makefile
@@ -4,10 +4,12 @@
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
+
+JFFS2_BLOCKSIZE=256k
+
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
-JFFS2_BLOCKSIZE=256k
define Image/Prepare
$(LINUX_DIR)/scripts/dtc/dtc -O dtb -R 4 -S 0x20000 $(DTS_DIR)/canyonlands.dts > $(KDIR)/openwrt-canyonlands.dtb
diff --git a/target/linux/xburst/image/Makefile b/target/linux/xburst/image/Makefile
index 3795454c07..0853607506 100644
--- a/target/linux/xburst/image/Makefile
+++ b/target/linux/xburst/image/Makefile
@@ -4,11 +4,12 @@
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
-include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/image.mk
JFFS2_BLOCKSIZE=256k 512k
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
ifneq ($(CONFIG_TARGET_xburst_qi_lb60),)
UBI_OPTS = -m 4096 -p 512KiB
UBIFS_OPTS = -m 4096 -e 516096 -c 4095