summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2016-03-20 14:41:33 +0000
committerJohn Crispin <john@openwrt.org>2016-03-20 14:41:33 +0000
commitcc82da0bc10561b5af902fb8abaca1952b2c4bfb (patch)
tree8fa26bb0943d3ba974a8180074d9dc1df735cd36
parente9db6eb8b2c630b912c5ebf733eb39a4b38c0c57 (diff)
downloadmaster-31e0f0ae-cc82da0bc10561b5af902fb8abaca1952b2c4bfb.tar.gz
master-31e0f0ae-cc82da0bc10561b5af902fb8abaca1952b2c4bfb.tar.bz2
master-31e0f0ae-cc82da0bc10561b5af902fb8abaca1952b2c4bfb.zip
ramips: MiWifi-Nano - change gpios to leds, add to default build group
1) Use leds to indicate: Red - Power Amber - Radio On Blue - Wifi associated 2) Add profile to default build group for MT7628 subtarget Signed-off-by: Noble Pepper <openwrtmail@noblepepper.com> SVN-Revision: 49045
-rwxr-xr-xtarget/linux/ramips/base-files/etc/board.d/01_leds5
-rw-r--r--target/linux/ramips/dts/MIWIFI-NANO.dts38
-rw-r--r--target/linux/ramips/image/Makefile1
3 files changed, 21 insertions, 23 deletions
diff --git a/target/linux/ramips/base-files/etc/board.d/01_leds b/target/linux/ramips/base-files/etc/board.d/01_leds
index 6c25c86753..5816e60f66 100755
--- a/target/linux/ramips/base-files/etc/board.d/01_leds
+++ b/target/linux/ramips/base-files/etc/board.d/01_leds
@@ -185,6 +185,11 @@ miniembplug)
miwifi-mini)
ucidef_set_led_default "power" "power" "$board:red:status" "1"
;;
+miwifi-nano)
+ ucidef_set_led_default "power" "power" "$board:red:status" "1"
+ ucidef_set_led_wlan "radio_led" "radio" "$board:amber:radio" "phy0radio"
+ ucidef_set_led_wlan "wifi_led" "wifi" "$board:blue:wifi" "phy0assoc"
+ ;;
mlw221|\
mlwg2)
set_wifi_led "$board:blue:wifi"
diff --git a/target/linux/ramips/dts/MIWIFI-NANO.dts b/target/linux/ramips/dts/MIWIFI-NANO.dts
index ea7b27035a..363b90d4ff 100644
--- a/target/linux/ramips/dts/MIWIFI-NANO.dts
+++ b/target/linux/ramips/dts/MIWIFI-NANO.dts
@@ -18,38 +18,30 @@
pinctrl {
state_default: pinctrl0 {
gpio {
- ralink,group = "gpio";
+ ralink,group = "refclk", "wled", "gpio";
ralink,function = "gpio";
};
};
};
- gpio-export {
- compatible = "gpio-export";
- #size-cells = <0>;
+ gpio-leds {
+ compatible = "gpio-leds";
- gpio11 {
- /* blue led */
- gpio-export,name = "gpio11";
- gpio-export,direction_may_change = <1>;
- gpio-export,output = <1>;
- gpios = <&gpio0 11 0>;
+ wifi {
+ label = "miwifi-nano:blue:wifi";
+ gpios = <&gpio0 11 1>;
+ default-state = "1";
};
-
- gpio37 {
- /* red led */
- gpio-export,name = "gpio37";
- gpio-export,direction_may_change = <1>;
- gpio-export,output = <1>;
- gpios = <&gpio1 5 0>;
+ status {
+ label = "miwifi-nano:red:status";
+ gpios = <&gpio1 5 1>;
+ default-state = "on";
};
+ radio {
+ label = "miwifi-nano:amber:radio";
+ gpios = <&gpio1 12 1>;
+ default-state = "1";
- gpio44 {
- /* yellow led */
- gpio-export,name = "gpio44";
- gpio-export,direction_may_change = <1>;
- gpio-export,output = <1>;
- gpios = <&gpio1 12 0>;
};
};
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 45cb22b09c..0cfb8fbc41 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -1154,6 +1154,7 @@ Image/Build/Profile/WRTNODE2P=$(call BuildFirmware/Default16M/$(1),$(1),wrtnode2
ifeq ($(SUBTARGET),mt7628)
define Image/Build/Profile/Default
+ $(call Image/Build/Profile/MIWIFI-NANO,$(1))
$(call Image/Build/Profile/MT7628,$(1))
$(call Image/Build/Profile/WRTNODE2P,$(1))
endef