summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2013-09-19 05:56:46 +0000
committerJohn Crispin <john@openwrt.org>2013-09-19 05:56:46 +0000
commitc0f6bf05f4b73d4541865db9785fe691666774cb (patch)
tree82c6fd1bf791b227042a1f8879fba3008bf9e5a9
parent898c164b464dda4e829b0d064d9c3b10161f4a39 (diff)
downloadmaster-31e0f0ae-c0f6bf05f4b73d4541865db9785fe691666774cb.tar.gz
master-31e0f0ae-c0f6bf05f4b73d4541865db9785fe691666774cb.tar.bz2
master-31e0f0ae-c0f6bf05f4b73d4541865db9785fe691666774cb.zip
ralink: add support for dalink dcs930l ipcam
Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 38053
-rwxr-xr-xtarget/linux/ramips/base-files/etc/diag.sh2
-rw-r--r--target/linux/ramips/base-files/etc/hotplug.d/firmware/10-rt2x00-eeprom1
-rwxr-xr-xtarget/linux/ramips/base-files/etc/uci-defaults/02_network1
-rwxr-xr-xtarget/linux/ramips/base-files/lib/ramips.sh3
-rwxr-xr-xtarget/linux/ramips/base-files/lib/upgrade/platform.sh1
-rw-r--r--target/linux/ramips/dts/DCS-930.dts118
-rw-r--r--target/linux/ramips/image/Makefile3
-rw-r--r--target/linux/ramips/rt305x/profiles/dlink.mk12
8 files changed, 140 insertions, 1 deletions
diff --git a/target/linux/ramips/base-files/etc/diag.sh b/target/linux/ramips/base-files/etc/diag.sh
index c8f73e7971..bfe53e1d9e 100755
--- a/target/linux/ramips/base-files/etc/diag.sh
+++ b/target/linux/ramips/base-files/etc/diag.sh
@@ -27,7 +27,7 @@ get_status_led() {
d105)
status_led="d105:red:power"
;;
- dir-300-b1 | dir-600-b1 | dir-600-b2 | dir-610-a1 | dir-615-h1 | dir-615-d | dir-620-a1| dir-620-d1| dir-300-b7| dir-320-b1)
+ dcs-930 | dir-300-b1 | dir-600-b1 | dir-600-b2 | dir-610-a1 | dir-615-h1 | dir-615-d | dir-620-a1| dir-620-d1| dir-300-b7| dir-320-b1)
status_led="d-link:green:status"
;;
dir-645)
diff --git a/target/linux/ramips/base-files/etc/hotplug.d/firmware/10-rt2x00-eeprom b/target/linux/ramips/base-files/etc/hotplug.d/firmware/10-rt2x00-eeprom
index a56781787d..b0b071774a 100644
--- a/target/linux/ramips/base-files/etc/hotplug.d/firmware/10-rt2x00-eeprom
+++ b/target/linux/ramips/base-files/etc/hotplug.d/firmware/10-rt2x00-eeprom
@@ -68,6 +68,7 @@ case "$FIRMWARE" in
br6524n | \
carambola | \
d105 | \
+ dcs-930 | \
dir-300-b7 | \
dir-320-b1 | \
dir-610-a1 | \
diff --git a/target/linux/ramips/base-files/etc/uci-defaults/02_network b/target/linux/ramips/base-files/etc/uci-defaults/02_network
index 0184ef4df7..345bd81a0b 100755
--- a/target/linux/ramips/base-files/etc/uci-defaults/02_network
+++ b/target/linux/ramips/base-files/etc/uci-defaults/02_network
@@ -43,6 +43,7 @@ ramips_setup_interfaces()
all5003 | \
awm002-evb | \
broadway | \
+ dcs-930| \
wnce2001)
ucidef_add_switch "switch0" "1" "0"
ucidef_set_interface_lan "eth0"
diff --git a/target/linux/ramips/base-files/lib/ramips.sh b/target/linux/ramips/base-files/lib/ramips.sh
index a92e8189b9..494f9d4d0d 100755
--- a/target/linux/ramips/base-files/lib/ramips.sh
+++ b/target/linux/ramips/base-files/lib/ramips.sh
@@ -64,6 +64,9 @@ ramips_board_detect() {
*"Aztech HW550-3G")
name="hw550-3g"
;;
+ *"DCS-930")
+ name="dcs-930"
+ ;;
*"DIR-300 B1")
name="dir-300-b1"
;;
diff --git a/target/linux/ramips/base-files/lib/upgrade/platform.sh b/target/linux/ramips/base-files/lib/upgrade/platform.sh
index cc8ca89aa5..e7087cc673 100755
--- a/target/linux/ramips/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ramips/base-files/lib/upgrade/platform.sh
@@ -29,6 +29,7 @@ platform_check_image() {
broadway | \
carambola | \
d105 | \
+ dcs-930 | \
dir-300-b1 | \
dir-300-b7 | \
dir-320-b1 | \
diff --git a/target/linux/ramips/dts/DCS-930.dts b/target/linux/ramips/dts/DCS-930.dts
new file mode 100644
index 0000000000..31dab45814
--- /dev/null
+++ b/target/linux/ramips/dts/DCS-930.dts
@@ -0,0 +1,118 @@
+/dts-v1/;
+
+/include/ "rt3050.dtsi"
+
+/ {
+ compatible = "DCS-930", "ralink,rt3050-soc";
+ model = "D-Link DCS-930";
+
+ pinctrl {
+ state_default: pinctrl0 {
+ gpio {
+ ralink,group = "i2c", "spi", "jtag", "mdio", "rgmii", "uartf";
+ ralink,function = "gpio";
+ };
+ };
+ };
+
+ cfi@1f000000 {
+ compatible = "cfi-flash";
+ reg = <0x1f000000 0x400000>;
+
+ bank-width = <2>;
+ device-width = <2>;
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ partition@0 {
+ label = "u-boot";
+ reg = <0x0 0x30000>;
+ read-only;
+ };
+
+ partition@30000 {
+ label = "u-boot-env";
+ reg = <0x30000 0x10000>;
+ read-only;
+ };
+
+ factory: partition@40000 {
+ label = "factory";
+ reg = <0x40000 0x10000>;
+ read-only;
+ };
+
+ partition@50000 {
+ label = "firmware";
+ reg = <0x50000 0x3b0000>;
+ };
+ };
+
+ gpio-leds {
+ compatible = "gpio-leds";
+ wifi {
+ label = "d-link:red:alert";
+ gpios = <&gpio0 8 1>;
+ };
+ power {
+ label = "d-link:green:status";
+ gpios = <&gpio0 9 1>;
+ };
+ wps {
+ label = "d-link:blue:wps";
+ gpios = <&gpio0 13 1>;
+ };
+ };
+
+ gpio-keys-polled {
+ compatible = "gpio-keys-polled";
+ #address-cells = <1>;
+ #size-cells = <0>;
+ poll-interval = <20>;
+
+ wps {
+ label = "wps";
+ gpios = <&gpio0 0 1>;
+ linux,code = <0x101>;
+ };
+ reset {
+ label = "reset";
+ gpios = <&gpio0 10 1>;
+ linux,code = <0x198>;
+ };
+ };
+
+ esw@10110000 {
+ ralink,portmap = <0x2f>;
+
+ port@0 {
+ compatible = "swconfig,port";
+ swconfig,segment = "lan";
+ swconfig,portmap = <0 4>;
+ };
+ port@1 {
+ compatible = "swconfig,port";
+ swconfig,segment = "lan";
+ swconfig,portmap = <1 3>;
+ };
+ port@2 {
+ compatible = "swconfig,port";
+ swconfig,segment = "lan";
+ swconfig,portmap = <2 2>;
+ };
+ port@3 {
+ compatible = "swconfig,port";
+ swconfig,segment = "lan";
+ swconfig,portmap = <3 1>;
+ };
+ port@4 {
+ compatible = "swconfig,port";
+ swconfig,segment = "wan";
+ swconfig,portmap = <4 0>;
+ };
+ };
+
+ otg@101c0000 {
+ status = "okay";
+ };
+};
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index f4bb5686e8..5ee76a6057 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -357,6 +357,8 @@ Image/Build/Profile/DAP1350=$(call BuildFirmware/dap1350/$(1),$(1),dap-1350,DAP-
Image/Build/Profile/DAP1350WW=$(call BuildFirmware/dap1350/$(1),$(1),dap-1350WW,DAP-1350,RT3052-AP-DAP1350WW-3)
+Image/Build/Profile/DCS930=$(call BuildFirmware/Default4M/$(1),$(1),dcs-930,DCS-930)
+
Image/Build/Profile/ESR-9753=$(call BuildFirmware/Default4M/$(1),$(1),esr-9753,ESR-9753)
Image/Build/Profile/HW550-3G=$(call BuildFirmware/Default8M/$(1),$(1),hw550-3g,HW550-3G)
@@ -519,6 +521,7 @@ define Image/Build/Profile/Default
$(call Image/Build/Profile/DIR615H1,$(1))
$(call Image/Build/Profile/DAP1350,$(1))
$(call Image/Build/Profile/DAP1350WW,$(1))
+ $(call Image/Build/Profile/DCS930,$(1))
$(call Image/Build/Profile/ESR-9753,$(1))
$(call Image/Build/Profile/F7C027,$(1))
$(call Image/Build/Profile/F5D8235V2,$(1))
diff --git a/target/linux/ramips/rt305x/profiles/dlink.mk b/target/linux/ramips/rt305x/profiles/dlink.mk
index 877724d886..5c5ea8fc90 100644
--- a/target/linux/ramips/rt305x/profiles/dlink.mk
+++ b/target/linux/ramips/rt305x/profiles/dlink.mk
@@ -18,6 +18,18 @@ endef
$(eval $(call Profile,DIR615H1))
+define Profile/DCS930
+ NAME:=Dlink DCS-930
+ PACKAGES:=kmod-video-core kmod-video-uvc \
+ kmod-usb-core kmod-usb-rt305x-dwc_otg
+endef
+
+define Profile/DCS930/Description
+ Package set for Dlink DCS-930 board
+endef
+
+$(eval $(call Profile,DCS930))
+
define Profile/DIR610A1
NAME:=Dlink DIR-610 A1
PACKAGES:=kmod-ledtrig-netdev kmod-ledtrig-timer