summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2013-03-03 21:59:34 +0000
committerLuka Perkov <luka@openwrt.org>2013-03-03 21:59:34 +0000
commita5ebfc79ba93446ea576153c77f74d41c53c4d56 (patch)
treeb864216a97218c97a34d0246536ae1d93f798c13
parent7f0cc47d8575d68bab55ad3d192f0815dced6a4a (diff)
downloadmaster-31e0f0ae-a5ebfc79ba93446ea576153c77f74d41c53c4d56.tar.gz
master-31e0f0ae-a5ebfc79ba93446ea576153c77f74d41c53c4d56.tar.bz2
master-31e0f0ae-a5ebfc79ba93446ea576153c77f74d41c53c4d56.zip
ar71xx: rework changes from r35840
Signed-off-by: Luka Perkov <luka@openwrt.org> Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 35865
-rwxr-xr-xtarget/linux/ar71xx/base-files/etc/diag.sh3
-rw-r--r--target/linux/ar71xx/base-files/etc/hotplug.d/net/10-ar922x-led-fix3
-rwxr-xr-xtarget/linux/ar71xx/base-files/etc/uci-defaults/01_leds3
-rwxr-xr-xtarget/linux/ar71xx/base-files/etc/uci-defaults/02_network3
-rwxr-xr-xtarget/linux/ar71xx/base-files/etc/uci-defaults/03_network-switchX-migration1
-rwxr-xr-xtarget/linux/ar71xx/base-files/lib/ar71xx.sh5
-rwxr-xr-xtarget/linux/ar71xx/base-files/lib/upgrade/platform.sh1
-rw-r--r--target/linux/ar71xx/config-3.71
-rw-r--r--target/linux/ar71xx/config-3.81
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/mach-wzr-hp-ag300h.c7
-rw-r--r--target/linux/ar71xx/image/Makefile2
-rw-r--r--target/linux/ar71xx/patches-3.7/610-MIPS-ath79-openwrt-machines.patch25
-rw-r--r--target/linux/ar71xx/patches-3.7/612-MIPS-ath79-add-DIR-825-C1-support.patch2
-rw-r--r--target/linux/ar71xx/patches-3.7/613-MIPS-ath79-add-TL-WDR3500-support.patch2
-rw-r--r--target/linux/ar71xx/patches-3.7/615-MIPS-ath79-RB951G-support.patch2
-rw-r--r--target/linux/ar71xx/patches-3.8/610-MIPS-ath79-openwrt-machines.patch25
-rw-r--r--target/linux/ar71xx/patches-3.8/612-MIPS-ath79-add-DIR-825-C1-support.patch2
-rw-r--r--target/linux/ar71xx/patches-3.8/613-MIPS-ath79-add-TL-WDR3500-support.patch2
-rw-r--r--target/linux/ar71xx/patches-3.8/615-MIPS-ath79-RB951G-support.patch2
19 files changed, 28 insertions, 64 deletions
diff --git a/target/linux/ar71xx/base-files/etc/diag.sh b/target/linux/ar71xx/base-files/etc/diag.sh
index c863b21a81..adf32f12fb 100755
--- a/target/linux/ar71xx/base-files/etc/diag.sh
+++ b/target/linux/ar71xx/base-files/etc/diag.sh
@@ -152,8 +152,7 @@ get_status_led() {
status_led="buffalo:green:status"
;;
wzr-hp-ag300h | \
- wzr-hp-g300nh2 | \
- wzr-600dhp)
+ wzr-hp-g300nh2)
status_led="buffalo:red:diag"
;;
wndr3700)
diff --git a/target/linux/ar71xx/base-files/etc/hotplug.d/net/10-ar922x-led-fix b/target/linux/ar71xx/base-files/etc/hotplug.d/net/10-ar922x-led-fix
index 6a7f521afa..102415009b 100644
--- a/target/linux/ar71xx/base-files/etc/hotplug.d/net/10-ar922x-led-fix
+++ b/target/linux/ar71xx/base-files/etc/hotplug.d/net/10-ar922x-led-fix
@@ -42,8 +42,7 @@ if [ $phyname -a $ACTION = "add" ]; then
. /lib/ar71xx.sh
case $(ar71xx_board_name) in
- wzr-hp-ag300h|\
- wzr-600dhp)
+ wzr-hp-ag300h)
ar922x_disable_gpio_jtag $phyname
;;
esac;
diff --git a/target/linux/ar71xx/base-files/etc/uci-defaults/01_leds b/target/linux/ar71xx/base-files/etc/uci-defaults/01_leds
index 3e54d64d03..392439385b 100755
--- a/target/linux/ar71xx/base-files/etc/uci-defaults/01_leds
+++ b/target/linux/ar71xx/base-files/etc/uci-defaults/01_leds
@@ -212,8 +212,7 @@ wlae-ag300n)
ucidef_set_led_netdev "wireless" "WIRELESS" "buffalo:green:wireless" "wlan0"
;;
-wzr-hp-ag300h | \
-wzr-600dhp)
+wzr-hp-ag300h)
ucidef_set_led_default "diag" "DIAG" "buffalo:red:diag" "0"
ucidef_set_led_netdev "router" "ROUTER" "buffalo:green:router" "eth1"
ucidef_set_led_usbdev "usb" "USB" "buffalo:green:usb" "1-1"
diff --git a/target/linux/ar71xx/base-files/etc/uci-defaults/02_network b/target/linux/ar71xx/base-files/etc/uci-defaults/02_network
index 15a1d39ac4..b1f84da605 100755
--- a/target/linux/ar71xx/base-files/etc/uci-defaults/02_network
+++ b/target/linux/ar71xx/base-files/etc/uci-defaults/02_network
@@ -233,8 +233,7 @@ tl-wr841n-v7 |\
whr-g301n |\
whr-hp-g300n |\
whr-hp-gn |\
-wzr-hp-ag300h |\
-wzr-600dhp)
+wzr-hp-ag300h)
ucidef_set_interfaces_lan_wan "eth0" "eth1"
ucidef_add_switch "switch0" "1" "1"
ucidef_add_switch_vlan "switch0" "1" "0 1 2 3 4"
diff --git a/target/linux/ar71xx/base-files/etc/uci-defaults/03_network-switchX-migration b/target/linux/ar71xx/base-files/etc/uci-defaults/03_network-switchX-migration
index 8757b21a80..718a924f19 100755
--- a/target/linux/ar71xx/base-files/etc/uci-defaults/03_network-switchX-migration
+++ b/target/linux/ar71xx/base-files/etc/uci-defaults/03_network-switchX-migration
@@ -75,7 +75,6 @@ whr-hp-g300n|\
whr-hp-gn|\
wzr-hp-ag300h|\
wzr-hp-g450h|\
-wzr-600dhp|\
ew-dorin|\
ew-dorin-router)
migrate_switch_name "eth0" "switch0"
diff --git a/target/linux/ar71xx/base-files/lib/ar71xx.sh b/target/linux/ar71xx/base-files/lib/ar71xx.sh
index 84751e8b19..4fd48d5cc0 100755
--- a/target/linux/ar71xx/base-files/lib/ar71xx.sh
+++ b/target/linux/ar71xx/base-files/lib/ar71xx.sh
@@ -456,7 +456,7 @@ ar71xx_board_detect() {
*WRT400N)
name="wrt400n"
;;
- *WZR-HP-AG300H)
+ *"WZR-HP-AG300H/WZR-600DHP")
name="wzr-hp-ag300h"
;;
*WZR-HP-G300NH)
@@ -468,9 +468,6 @@ ar71xx_board_detect() {
*WZR-HP-G300NH2)
name="wzr-hp-g300nh2"
;;
- *WZR-600DHP)
- name="wzr-600dhp"
- ;;
*WHR-HP-G300N)
name="whr-hp-g300n"
;;
diff --git a/target/linux/ar71xx/base-files/lib/upgrade/platform.sh b/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
index d3e14d16ad..c16d184e73 100755
--- a/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
@@ -125,7 +125,6 @@ platform_check_image() {
wzr-hp-g300nh | \
wzr-hp-g450h | \
wzr-hp-ag300h | \
- wzr-600dhp | \
whr-g301n | \
whr-hp-g300n | \
whr-hp-gn | \
diff --git a/target/linux/ar71xx/config-3.7 b/target/linux/ar71xx/config-3.7
index 7e07a957f7..98f099623d 100644
--- a/target/linux/ar71xx/config-3.7
+++ b/target/linux/ar71xx/config-3.7
@@ -92,7 +92,6 @@ CONFIG_ATH79_MACH_WZR_HP_AG300H=y
CONFIG_ATH79_MACH_WZR_HP_G300NH=y
CONFIG_ATH79_MACH_WZR_HP_G300NH2=y
CONFIG_ATH79_MACH_WZR_HP_G450H=y
-CONFIG_ATH79_MACH_WZR_600DHP=y
CONFIG_ATH79_MACH_ZCN_1523H=y
CONFIG_ATH79_NVRAM=y
CONFIG_ATH79_PCI_ATH9K_FIXUP=y
diff --git a/target/linux/ar71xx/config-3.8 b/target/linux/ar71xx/config-3.8
index 898236e295..847b9a5034 100644
--- a/target/linux/ar71xx/config-3.8
+++ b/target/linux/ar71xx/config-3.8
@@ -92,7 +92,6 @@ CONFIG_ATH79_MACH_WZR_HP_AG300H=y
CONFIG_ATH79_MACH_WZR_HP_G300NH=y
CONFIG_ATH79_MACH_WZR_HP_G300NH2=y
CONFIG_ATH79_MACH_WZR_HP_G450H=y
-CONFIG_ATH79_MACH_WZR_600DHP=y
CONFIG_ATH79_MACH_ZCN_1523H=y
CONFIG_ATH79_NVRAM=y
CONFIG_ATH79_PCI_ATH9K_FIXUP=y
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/mach-wzr-hp-ag300h.c b/target/linux/ar71xx/files/arch/mips/ath79/mach-wzr-hp-ag300h.c
index aa035c81b1..9ba5ecd2ea 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/mach-wzr-hp-ag300h.c
+++ b/target/linux/ar71xx/files/arch/mips/ath79/mach-wzr-hp-ag300h.c
@@ -36,6 +36,7 @@ static struct mtd_partition wzrhpag300h_flash_partitions[] = {
.name = "u-boot-env",
.offset = 0x0040000,
.size = 0x0010000,
+ .mask_flags = MTD_WRITEABLE,
}, {
.name = "art",
.offset = 0x0050000,
@@ -209,8 +210,4 @@ static void __init wzrhpag300h_setup(void)
}
MIPS_MACHINE(ATH79_MACH_WZR_HP_AG300H, "WZR-HP-AG300H",
- "Buffalo WZR-HP-AG300H", wzrhpag300h_setup);
-
-MIPS_MACHINE(ATH79_MACH_WZR_600DHP, "WZR-600DHP",
- "Buffalo WZR-600DHP", wzrhpag300h_setup);
-
+ "Buffalo WZR-HP-AG300H/WZR-600DHP", wzrhpag300h_setup);
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index a34828cfad..63abfe7ace 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -960,7 +960,7 @@ $(eval $(call SingleProfile,WZRHPG30XNH,$(fs_128k),WZRHPG300NH,wzr-hp-g300nh,WZR
$(eval $(call SingleProfile,WZRHPG30XNH,$(fs_64k),WZRHPG300NH2,wzr-hp-g300nh2,WZR-HP-G300NH2,ttyS0,115200,WZR-HP-G300NH2))
$(eval $(call SingleProfile,WZRHPG30XNH,$(fs_64k),WZRHPAG300H,wzr-hp-ag300h,WZR-HP-AG300H,ttyS0,115200,WZR-HP-AG300H))
$(eval $(call SingleProfile,WZRHPG30XNH,$(fs_64k),WZRHPG450H,wzr-hp-g450h,WZR-HP-G450H,ttyS0,115200,WZR-HP-AG450H))
-$(eval $(call SingleProfile,WZRHPG30XNH,$(fs_64k),WZR600DHP,wzr-600dhp,WZR-600DHP,ttyS0,115200,WZR-600DHP))
+$(eval $(call SingleProfile,WZRHPG30XNH,$(fs_64k),WZR600DHP,wzr-600dhp,WZR-HP-AG300H,ttyS0,115200,WZR-600DHP))
$(eval $(call SingleProfile,Zcomax,$(fs_64k),ZCN1523H28,zcn-1523h-2-8,ZCN-1523H-2,ttyS0,115200,$$(zcn1523h_mtdlayout)))
$(eval $(call SingleProfile,Zcomax,$(fs_64k),ZCN1523H516,zcn-1523h-5-16,ZCN-1523H-5,ttyS0,115200,$$(zcn1523h_mtdlayout)))
diff --git a/target/linux/ar71xx/patches-3.7/610-MIPS-ath79-openwrt-machines.patch b/target/linux/ar71xx/patches-3.7/610-MIPS-ath79-openwrt-machines.patch
index bdf8c2be23..73253bb5ab 100644
--- a/target/linux/ar71xx/patches-3.7/610-MIPS-ath79-openwrt-machines.patch
+++ b/target/linux/ar71xx/patches-3.7/610-MIPS-ath79-openwrt-machines.patch
@@ -1,6 +1,6 @@
--- a/arch/mips/ath79/machtypes.h
+++ b/arch/mips/ath79/machtypes.h
-@@ -16,22 +16,113 @@
+@@ -16,22 +16,112 @@
enum ath79_mach_type {
ATH79_MACH_GENERIC = 0,
@@ -108,7 +108,6 @@
+ ATH79_MACH_WZR_HP_G300NH, /* Buffalo WZR-HP-G300NH */
+ ATH79_MACH_WZR_HP_G300NH2, /* Buffalo WZR-HP-G300NH2 */
+ ATH79_MACH_WZR_HP_G450H, /* Buffalo WZR-HP-G450H */
-+ ATH79_MACH_WZR_600DHP, /* Buffalo WZR-600DHP */
+ ATH79_MACH_ZCN_1523H_2, /* Zcomax ZCN-1523H-2-xx */
+ ATH79_MACH_ZCN_1523H_5, /* Zcomax ZCN-1523H-5-xx */
};
@@ -217,7 +216,7 @@
config ATH79_MACH_PB44
bool "Atheros PB44 reference board"
select SOC_AR71XX
-@@ -68,6 +148,497 @@ config ATH79_MACH_PB44
+@@ -68,6 +148,488 @@ config ATH79_MACH_PB44
Say 'Y' here if you want your kernel to support the
Atheros PB44 reference board.
@@ -294,15 +293,6 @@
+ select ATH79_DEV_M25P80
+ select ATH79_DEV_USB
+
-+config ATH79_MACH_WZR_600DHP
-+ bool "Buffalo WZR-600DHP board support"
-+ select SOC_AR71XX
-+ select ATH79_DEV_ETH
-+ select ATH79_DEV_GPIO_BUTTONS
-+ select ATH79_DEV_LEDS_GPIO
-+ select ATH79_DEV_M25P80
-+ select ATH79_DEV_USB
-+
+config ATH79_MACH_WP543
+ bool "Compex WP543/WPJ543 board support"
+ select SOC_AR71XX
@@ -715,7 +705,7 @@
config ATH79_MACH_UBNT_XM
bool "Ubiquiti Networks XM/UniFi boards"
select SOC_AR724X
-@@ -83,6 +654,24 @@ config ATH79_MACH_UBNT_XM
+@@ -83,6 +645,24 @@ config ATH79_MACH_UBNT_XM
Say 'Y' here if you want your kernel to support the
Ubiquiti Networks XM (rev 1.0) board.
@@ -740,7 +730,7 @@
endmenu
config SOC_AR71XX
-@@ -118,10 +707,6 @@ config SOC_QCA955X
+@@ -118,10 +698,6 @@ config SOC_QCA955X
select PCI_AR724X if PCI
def_bool n
@@ -751,7 +741,7 @@
config ATH79_DEV_AP9X_PCI
select ATH79_PCI_ATH9K_FIXUP
def_bool n
-@@ -132,7 +717,14 @@ config ATH79_DEV_DSA
+@@ -132,7 +708,14 @@ config ATH79_DEV_DSA
config ATH79_DEV_ETH
def_bool n
@@ -767,7 +757,7 @@
def_bool n
config ATH79_DEV_GPIO_BUTTONS
-@@ -164,4 +756,7 @@ config ATH79_PCI_ATH9K_FIXUP
+@@ -164,4 +747,7 @@ config ATH79_PCI_ATH9K_FIXUP
config ATH79_ROUTERBOOT
def_bool n
@@ -777,7 +767,7 @@
endif
--- a/arch/mips/ath79/Makefile
+++ b/arch/mips/ath79/Makefile
-@@ -38,9 +38,72 @@ obj-$(CONFIG_ATH79_ROUTERBOOT) += route
+@@ -38,9 +38,71 @@ obj-$(CONFIG_ATH79_ROUTERBOOT) += route
#
# Machines
#
@@ -847,7 +837,6 @@
+obj-$(CONFIG_ATH79_MACH_WZR_HP_G300NH2) += mach-wzr-hp-g300nh2.o
+obj-$(CONFIG_ATH79_MACH_WZR_HP_AG300H) += mach-wzr-hp-ag300h.o
+obj-$(CONFIG_ATH79_MACH_WZR_HP_G450H) += mach-wzr-hp-g450h.o
-+obj-$(CONFIG_ATH79_MACH_WZR_600DHP) += mach-wzr-hp-ag300h.o
+obj-$(CONFIG_ATH79_MACH_ZCN_1523H) += mach-zcn-1523h.o
+
--- a/arch/mips/ath79/prom.c
diff --git a/target/linux/ar71xx/patches-3.7/612-MIPS-ath79-add-DIR-825-C1-support.patch b/target/linux/ar71xx/patches-3.7/612-MIPS-ath79-add-DIR-825-C1-support.patch
index 5722ed1fb6..5d6f5cb226 100644
--- a/target/linux/ar71xx/patches-3.7/612-MIPS-ath79-add-DIR-825-C1-support.patch
+++ b/target/linux/ar71xx/patches-3.7/612-MIPS-ath79-add-DIR-825-C1-support.patch
@@ -10,7 +10,7 @@
ATH79_MACH_EAP7660D, /* Senao EAP7660D */
--- a/arch/mips/ath79/Kconfig
+++ b/arch/mips/ath79/Kconfig
-@@ -292,6 +292,17 @@ config ATH79_MACH_DIR_825_B1
+@@ -283,6 +283,17 @@ config ATH79_MACH_DIR_825_B1
select ATH79_DEV_M25P80
select ATH79_DEV_USB
diff --git a/target/linux/ar71xx/patches-3.7/613-MIPS-ath79-add-TL-WDR3500-support.patch b/target/linux/ar71xx/patches-3.7/613-MIPS-ath79-add-TL-WDR3500-support.patch
index cc60e78e43..0a2c3bda51 100644
--- a/target/linux/ar71xx/patches-3.7/613-MIPS-ath79-add-TL-WDR3500-support.patch
+++ b/target/linux/ar71xx/patches-3.7/613-MIPS-ath79-add-TL-WDR3500-support.patch
@@ -10,7 +10,7 @@
ATH79_MACH_TL_WR1043ND, /* TP-LINK TL-WR1043ND */
--- a/arch/mips/ath79/Kconfig
+++ b/arch/mips/ath79/Kconfig
-@@ -523,6 +523,17 @@ config ATH79_MACH_TL_WA901ND_V2
+@@ -514,6 +514,17 @@ config ATH79_MACH_TL_WA901ND_V2
select ATH79_DEV_M25P80
select ATH79_DEV_WMAC
diff --git a/target/linux/ar71xx/patches-3.7/615-MIPS-ath79-RB951G-support.patch b/target/linux/ar71xx/patches-3.7/615-MIPS-ath79-RB951G-support.patch
index 07bf886793..e679717366 100644
--- a/target/linux/ar71xx/patches-3.7/615-MIPS-ath79-RB951G-support.patch
+++ b/target/linux/ar71xx/patches-3.7/615-MIPS-ath79-RB951G-support.patch
@@ -10,7 +10,7 @@
ATH79_MACH_RW2458N, /* Redwave RW2458N */
--- a/arch/mips/ath79/Kconfig
+++ b/arch/mips/ath79/Kconfig
-@@ -369,6 +369,16 @@ config ATH79_MACH_RB750
+@@ -360,6 +360,16 @@ config ATH79_MACH_RB750
select ATH79_ROUTERBOOT
select RLE_DECOMPRESS
diff --git a/target/linux/ar71xx/patches-3.8/610-MIPS-ath79-openwrt-machines.patch b/target/linux/ar71xx/patches-3.8/610-MIPS-ath79-openwrt-machines.patch
index bdf8c2be23..73253bb5ab 100644
--- a/target/linux/ar71xx/patches-3.8/610-MIPS-ath79-openwrt-machines.patch
+++ b/target/linux/ar71xx/patches-3.8/610-MIPS-ath79-openwrt-machines.patch
@@ -1,6 +1,6 @@
--- a/arch/mips/ath79/machtypes.h
+++ b/arch/mips/ath79/machtypes.h
-@@ -16,22 +16,113 @@
+@@ -16,22 +16,112 @@
enum ath79_mach_type {
ATH79_MACH_GENERIC = 0,
@@ -108,7 +108,6 @@
+ ATH79_MACH_WZR_HP_G300NH, /* Buffalo WZR-HP-G300NH */
+ ATH79_MACH_WZR_HP_G300NH2, /* Buffalo WZR-HP-G300NH2 */
+ ATH79_MACH_WZR_HP_G450H, /* Buffalo WZR-HP-G450H */
-+ ATH79_MACH_WZR_600DHP, /* Buffalo WZR-600DHP */
+ ATH79_MACH_ZCN_1523H_2, /* Zcomax ZCN-1523H-2-xx */
+ ATH79_MACH_ZCN_1523H_5, /* Zcomax ZCN-1523H-5-xx */
};
@@ -217,7 +216,7 @@
config ATH79_MACH_PB44
bool "Atheros PB44 reference board"
select SOC_AR71XX
-@@ -68,6 +148,497 @@ config ATH79_MACH_PB44
+@@ -68,6 +148,488 @@ config ATH79_MACH_PB44
Say 'Y' here if you want your kernel to support the
Atheros PB44 reference board.
@@ -294,15 +293,6 @@
+ select ATH79_DEV_M25P80
+ select ATH79_DEV_USB
+
-+config ATH79_MACH_WZR_600DHP
-+ bool "Buffalo WZR-600DHP board support"
-+ select SOC_AR71XX
-+ select ATH79_DEV_ETH
-+ select ATH79_DEV_GPIO_BUTTONS
-+ select ATH79_DEV_LEDS_GPIO
-+ select ATH79_DEV_M25P80
-+ select ATH79_DEV_USB
-+
+config ATH79_MACH_WP543
+ bool "Compex WP543/WPJ543 board support"
+ select SOC_AR71XX
@@ -715,7 +705,7 @@
config ATH79_MACH_UBNT_XM
bool "Ubiquiti Networks XM/UniFi boards"
select SOC_AR724X
-@@ -83,6 +654,24 @@ config ATH79_MACH_UBNT_XM
+@@ -83,6 +645,24 @@ config ATH79_MACH_UBNT_XM
Say 'Y' here if you want your kernel to support the
Ubiquiti Networks XM (rev 1.0) board.
@@ -740,7 +730,7 @@
endmenu
config SOC_AR71XX
-@@ -118,10 +707,6 @@ config SOC_QCA955X
+@@ -118,10 +698,6 @@ config SOC_QCA955X
select PCI_AR724X if PCI
def_bool n
@@ -751,7 +741,7 @@
config ATH79_DEV_AP9X_PCI
select ATH79_PCI_ATH9K_FIXUP
def_bool n
-@@ -132,7 +717,14 @@ config ATH79_DEV_DSA
+@@ -132,7 +708,14 @@ config ATH79_DEV_DSA
config ATH79_DEV_ETH
def_bool n
@@ -767,7 +757,7 @@
def_bool n
config ATH79_DEV_GPIO_BUTTONS
-@@ -164,4 +756,7 @@ config ATH79_PCI_ATH9K_FIXUP
+@@ -164,4 +747,7 @@ config ATH79_PCI_ATH9K_FIXUP
config ATH79_ROUTERBOOT
def_bool n
@@ -777,7 +767,7 @@
endif
--- a/arch/mips/ath79/Makefile
+++ b/arch/mips/ath79/Makefile
-@@ -38,9 +38,72 @@ obj-$(CONFIG_ATH79_ROUTERBOOT) += route
+@@ -38,9 +38,71 @@ obj-$(CONFIG_ATH79_ROUTERBOOT) += route
#
# Machines
#
@@ -847,7 +837,6 @@
+obj-$(CONFIG_ATH79_MACH_WZR_HP_G300NH2) += mach-wzr-hp-g300nh2.o
+obj-$(CONFIG_ATH79_MACH_WZR_HP_AG300H) += mach-wzr-hp-ag300h.o
+obj-$(CONFIG_ATH79_MACH_WZR_HP_G450H) += mach-wzr-hp-g450h.o
-+obj-$(CONFIG_ATH79_MACH_WZR_600DHP) += mach-wzr-hp-ag300h.o
+obj-$(CONFIG_ATH79_MACH_ZCN_1523H) += mach-zcn-1523h.o
+
--- a/arch/mips/ath79/prom.c
diff --git a/target/linux/ar71xx/patches-3.8/612-MIPS-ath79-add-DIR-825-C1-support.patch b/target/linux/ar71xx/patches-3.8/612-MIPS-ath79-add-DIR-825-C1-support.patch
index 5722ed1fb6..5d6f5cb226 100644
--- a/target/linux/ar71xx/patches-3.8/612-MIPS-ath79-add-DIR-825-C1-support.patch
+++ b/target/linux/ar71xx/patches-3.8/612-MIPS-ath79-add-DIR-825-C1-support.patch
@@ -10,7 +10,7 @@
ATH79_MACH_EAP7660D, /* Senao EAP7660D */
--- a/arch/mips/ath79/Kconfig
+++ b/arch/mips/ath79/Kconfig
-@@ -292,6 +292,17 @@ config ATH79_MACH_DIR_825_B1
+@@ -283,6 +283,17 @@ config ATH79_MACH_DIR_825_B1
select ATH79_DEV_M25P80
select ATH79_DEV_USB
diff --git a/target/linux/ar71xx/patches-3.8/613-MIPS-ath79-add-TL-WDR3500-support.patch b/target/linux/ar71xx/patches-3.8/613-MIPS-ath79-add-TL-WDR3500-support.patch
index cc60e78e43..0a2c3bda51 100644
--- a/target/linux/ar71xx/patches-3.8/613-MIPS-ath79-add-TL-WDR3500-support.patch
+++ b/target/linux/ar71xx/patches-3.8/613-MIPS-ath79-add-TL-WDR3500-support.patch
@@ -10,7 +10,7 @@
ATH79_MACH_TL_WR1043ND, /* TP-LINK TL-WR1043ND */
--- a/arch/mips/ath79/Kconfig
+++ b/arch/mips/ath79/Kconfig
-@@ -523,6 +523,17 @@ config ATH79_MACH_TL_WA901ND_V2
+@@ -514,6 +514,17 @@ config ATH79_MACH_TL_WA901ND_V2
select ATH79_DEV_M25P80
select ATH79_DEV_WMAC
diff --git a/target/linux/ar71xx/patches-3.8/615-MIPS-ath79-RB951G-support.patch b/target/linux/ar71xx/patches-3.8/615-MIPS-ath79-RB951G-support.patch
index 07bf886793..e679717366 100644
--- a/target/linux/ar71xx/patches-3.8/615-MIPS-ath79-RB951G-support.patch
+++ b/target/linux/ar71xx/patches-3.8/615-MIPS-ath79-RB951G-support.patch
@@ -10,7 +10,7 @@
ATH79_MACH_RW2458N, /* Redwave RW2458N */
--- a/arch/mips/ath79/Kconfig
+++ b/arch/mips/ath79/Kconfig
-@@ -369,6 +369,16 @@ config ATH79_MACH_RB750
+@@ -360,6 +360,16 @@ config ATH79_MACH_RB750
select ATH79_ROUTERBOOT
select RLE_DECOMPRESS