summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2016-04-06 22:38:47 +0200
committerJo-Philipp Wich <jo@mein.io>2016-04-06 22:38:47 +0200
commit9e0401902468a84b701b6361546b9d4a5ff71215 (patch)
tree8bcf095ef28bc4d791319735bf585a64a90217e3
parentd87c303b588e89b8c2efcc678d34484bed653e88 (diff)
downloadmaster-31e0f0ae-9e0401902468a84b701b6361546b9d4a5ff71215.tar.gz
master-31e0f0ae-9e0401902468a84b701b6361546b9d4a5ff71215.tar.bz2
master-31e0f0ae-9e0401902468a84b701b6361546b9d4a5ff71215.zip
package: flag essential components as nonshared
Signed-off-by: Jo-Philipp Wich <jo@mein.io>
-rw-r--r--package/base-files/Makefile1
-rw-r--r--package/kernel/linux/Makefile1
-rw-r--r--package/libs/toolchain/Makefile2
-rw-r--r--package/system/opkg/Makefile1
-rw-r--r--package/system/procd/Makefile2
5 files changed, 6 insertions, 1 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 691ad517a7..2bc4d15ca4 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -12,6 +12,7 @@ include $(INCLUDE_DIR)/version.mk
PKG_NAME:=base-files
PKG_RELEASE:=168
+PKG_FLAGS:=nonshared
PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
PKG_BUILD_DEPENDS:=usign/host
diff --git a/package/kernel/linux/Makefile b/package/kernel/linux/Makefile
index 05b0b5e880..d85ce49387 100644
--- a/package/kernel/linux/Makefile
+++ b/package/kernel/linux/Makefile
@@ -49,6 +49,7 @@ define Package/kernel
TITLE:=Virtual kernel package
VERSION:=$(LINUX_VERSION)-$(LINUX_RELEASE)-$(LINUX_VERMAGIC)
URL:=http://www.kernel.org/
+ PKG_FLAGS:=nonshared
endef
define Package/kernel/install
diff --git a/package/libs/toolchain/Makefile b/package/libs/toolchain/Makefile
index 120193ad50..8efaef8ced 100644
--- a/package/libs/toolchain/Makefile
+++ b/package/libs/toolchain/Makefile
@@ -139,7 +139,7 @@ define Package/libc/Default
VERSION:=$(LIBC_VERSION)-$(PKG_RELEASE)
DEPENDS:=+libgcc
URL:=$(LIBC_URL)
- PKG_FLAGS:=hold essential
+ PKG_FLAGS:=hold essential nonshared
endef
diff --git a/package/system/opkg/Makefile b/package/system/opkg/Makefile
index d8cce2a8f2..01a7d796de 100644
--- a/package/system/opkg/Makefile
+++ b/package/system/opkg/Makefile
@@ -28,6 +28,7 @@ PKG_LICENSE_FILES:=COPYING
PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
+PKG_FLAGS := nonshared
PKG_CONFIG_DEPENDS := CONFIG_SIGNED_PACKAGES
PKG_BUILD_PARALLEL:=1
diff --git a/package/system/procd/Makefile b/package/system/procd/Makefile
index 294985c65e..0bf093f261 100644
--- a/package/system/procd/Makefile
+++ b/package/system/procd/Makefile
@@ -24,6 +24,8 @@ PKG_LICENSE_FILES:=
PKG_MAINTAINER:=John Crispin <blogic@openwrt.org>
+PKG_FLAGS:=nonshared
+
PKG_CONFIG_DEPENDS:= \
CONFIG_TARGET_INIT_PATH CONFIG_KERNEL_SECCOMP \
CONFIG_NAND_SUPPORT CONFIG_PROCD_SHOW_BOOT CONFIG_PROCD_ZRAM_TMPFS \